Bug 828309 - Upgrade from CloudForms 1.0 to CloudForms 1.0.1 requires additional data definition not provided by rails migration
Upgrade from CloudForms 1.0 to CloudForms 1.0.1 requires additional data defi...
Status: CLOSED DUPLICATE of bug 828317
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On: 827562 828317
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 10:33 EDT by Mike Orazi
Modified: 2012-06-04 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 827562
Environment:
Last Closed: 2012-06-04 11:29:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Orazi 2012-06-04 10:33:29 EDT
+++ This bug was initially created as a clone of Bug #827562 +++

Description of problem:
As an end user, I should be able to upgrade to new version of CloudForms and keep my existing data.

Scenario:
Users of CloudForms 1.0 who upgrade to 1.0.1 are missing a new set of Permissions granted to global image admin role. These were introduced in upstream commit 65c7767d226206d366eb423d3aeeefbfa9bca8e0 as part of the fix for https://bugzilla.redhat.com/show_bug.cgi?id=807745

While that patch provides a 'quick fix' to add the missing data definition in the form of a rake task ('rake dc:upgrade'), we need an easy route for the end user to apply the change.

A small script to stop aeolus-related services, run rake dc:upgrade, and restart services ought to be sufficient.

--- Additional comment from slinaber@redhat.com on 2012-06-01 17:52:45 EDT ---

4f2bf642a0a31bc686ac8fc83dff5f3a8a5d3f54 in aeolus-configure master branch

--- Additional comment from slinaber@redhat.com on 2012-06-01 18:33:02 EDT ---

5b34b65982e8ae2bac8f3fb050aef0b580e5df8f on conductor master branch
Comment 1 Steve Linabery 2012-06-04 11:29:35 EDT

*** This bug has been marked as a duplicate of bug 828317 ***

Note You need to log in before you can comment on or make changes to this bug.