Bug 828317 - Upgrade from CloudForms 1.0 to CloudForms 1.0.1 requires additional data definition not provided by rails migration
Upgrade from CloudForms 1.0 to CloudForms 1.0.1 requires additional data defi...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: 1.0.1
: ---
Assigned To: Angus Thomas
Rehana
: ZStream
: 828309 (view as bug list)
Depends On: 827562
Blocks: 828309
  Show dependency treegraph
 
Reported: 2012-06-04 10:47 EDT by Chris Pelland
Modified: 2012-07-10 03:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
As per BZ#826608, Conductor restricts private image views, which stops "Global Image Administrator" users from importing images. This update for Conductor provides a user-level script to add the missing data definitions: # /usr/share/aeolus-conductor/script/upgrade This script stops all Conductor services, adds the missing data definitions and restarts the services.
Story Points: ---
Clone Of: 827562
Environment:
Last Closed: 2012-07-10 03:23:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-06-04 10:47:43 EDT
+++ This bug was initially created as a clone of Bug #827562 +++

Description of problem:
As an end user, I should be able to upgrade to new version of CloudForms and keep my existing data.

Scenario:
Users of CloudForms 1.0 who upgrade to 1.0.1 are missing a new set of Permissions granted to global image admin role. These were introduced in upstream commit 65c7767d226206d366eb423d3aeeefbfa9bca8e0 as part of the fix for https://bugzilla.redhat.com/show_bug.cgi?id=807745

While that patch provides a 'quick fix' to add the missing data definition in the form of a rake task ('rake dc:upgrade'), we need an easy route for the end user to apply the change.

A small script to stop aeolus-related services, run rake dc:upgrade, and restart services ought to be sufficient.

--- Additional comment from slinaber@redhat.com on 2012-06-01 17:52:45 EDT ---

4f2bf642a0a31bc686ac8fc83dff5f3a8a5d3f54 in aeolus-configure master branch

--- Additional comment from slinaber@redhat.com on 2012-06-01 18:33:02 EDT ---

5b34b65982e8ae2bac8f3fb050aef0b580e5df8f on conductor master branch
Comment 1 Steve Linabery 2012-06-04 11:29:35 EDT
*** Bug 828309 has been marked as a duplicate of this bug. ***
Comment 2 Steve Linabery 2012-06-04 12:40:50 EDT
65e33529990110a252d425fac830f8d47414360e on conductor, 1.0.1 branch
997ea0d2cd09a9e3abe3250e3fb986b1a21d6787 on aeolus-configure, 1.0.1 branch
Comment 3 Dan Macpherson 2012-06-07 00:27:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
As per BZ#826608, Conductor restricts private image views, which stops "Global Image Administrator" users from importing images. This update for Conductor provides a user-level script to add the missing data definitions:

# /usr/share/aeolus-conductor/script/upgrade

This script stops all Conductor services, adds the missing data definitions and restarts the services.
Comment 4 Aziza Karol 2012-06-18 10:31:48 EDT
"Global Image Administrator" users are able to import image successfully.
Upgrade script adds the missing data definitions and restarts the services.

steps followed:
1.Installed cloudforms 1.0 and configured providers,lanched applications.
2.created a new user with global image administrator role.
3.login with the above user and tried importing image.Was not able to import.
4.upgraded cloudforms 1.0 to cloudforms 1.0.1
5.executed the upgrade script which added all missing data definitions.
6.login as global image administrator user and  import image.
7.image import successful.



rpm  -qa | grep aeolus
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
aeolus-configure-2.5.7-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.30-1.el6_2.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
aeolus-all-0.8.30-1.el6_2.noarch
Comment 6 errata-xmlrpc 2012-07-10 03:23:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.