Bug 828375 - (systemd-udev) SELinux is preventing /usr/sbin/NetworkManager from 'read' accesses on the chr_file null.
SELinux is preventing /usr/sbin/NetworkManager from 'read' accesses on the ch...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
abrt_hash:55a0fb43df863fa09d20a1b37a6...
:
: 828373 828376 828377 828378 828379 828380 828381 828382 828383 828384 828385 828386 828387 828388 828389 828390 828391 828392 828393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:32 EDT by Nicolas Mailhot
Modified: 2012-09-14 10:10 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 10:10:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:32:18 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:19:58 CEST

description:
:SELinux is preventing /usr/sbin/NetworkManager from 'read' accesses on the chr_file null.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that NetworkManager should be allowed read access on the null chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep NetworkManager /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                system_u:object_r:default_t:s0
:Target Objects                null [ chr_file ]
:Source                        NetworkManager
:Source Path                   /usr/sbin/NetworkManager
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           NetworkManager-0.9.4.0-9.git20120521.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    lun. 04 juin 2012 19:17:35 CEST
:Last Seen                     lun. 04 juin 2012 19:17:35 CEST
:Local ID                      d8645b4e-c4a3-4f0f-887d-c94036dfb1cb
:
:Raw Audit Messages
:type=AVC msg=audit(1338830255.969:122): avc:  denied  { read } for  pid=894 comm="NetworkManager" name="null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=AVC msg=audit(1338830255.969:122): avc:  denied  { open } for  pid=894 comm="NetworkManager" path="/dev/null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830255.969:122): arch=x86_64 syscall=open success=yes exit=ENOTBLK a0=36354ba00d a1=0 a2=cf60 a3=10 items=0 ppid=745 pid=894 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=NetworkManager exe=/usr/sbin/NetworkManager subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: NetworkManager,NetworkManager_t,default_t,chr_file,read
:
:audit2allow
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t default_t:chr_file { read open };
:
:audit2allow -R
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t default_t:chr_file { read open };
:
Comment 1 Daniel Walsh 2012-06-04 15:49:26 EDT
Caused by a bad systemd-udev package.
Comment 2 Daniel Walsh 2012-06-04 15:50:39 EDT
*** Bug 828373 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2012-06-04 15:50:46 EDT
*** Bug 828376 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2012-06-04 15:50:56 EDT
*** Bug 828377 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2012-06-04 15:51:03 EDT
*** Bug 828378 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2012-06-04 15:51:09 EDT
*** Bug 828379 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Walsh 2012-06-04 15:51:19 EDT
*** Bug 828380 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2012-06-04 15:51:30 EDT
*** Bug 828381 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Walsh 2012-06-04 15:51:35 EDT
*** Bug 828382 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Walsh 2012-06-04 15:51:42 EDT
*** Bug 828383 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Walsh 2012-06-04 15:51:50 EDT
*** Bug 828384 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Walsh 2012-06-04 15:51:57 EDT
*** Bug 828385 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Walsh 2012-06-04 15:52:52 EDT
*** Bug 828386 has been marked as a duplicate of this bug. ***
Comment 14 Daniel Walsh 2012-06-04 15:53:03 EDT
*** Bug 828387 has been marked as a duplicate of this bug. ***
Comment 15 Daniel Walsh 2012-06-04 15:53:10 EDT
*** Bug 828388 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Walsh 2012-06-04 15:53:17 EDT
*** Bug 828389 has been marked as a duplicate of this bug. ***
Comment 17 Daniel Walsh 2012-06-04 15:53:24 EDT
*** Bug 828390 has been marked as a duplicate of this bug. ***
Comment 18 Daniel Walsh 2012-06-04 15:53:31 EDT
*** Bug 828391 has been marked as a duplicate of this bug. ***
Comment 19 Daniel Walsh 2012-06-04 15:53:45 EDT
*** Bug 828392 has been marked as a duplicate of this bug. ***
Comment 20 Daniel Walsh 2012-06-04 15:53:48 EDT
*** Bug 828393 has been marked as a duplicate of this bug. ***
Comment 21 Lennart Poettering 2012-09-14 10:10:22 EDT
Should be fixed a while ago. Closing.

Note You need to log in before you can comment on or make changes to this bug.