Bug 828385 - SELinux is preventing /usr/sbin/rpcbind from read, write access on the chr_file null.
SELinux is preventing /usr/sbin/rpcbind from read, write access on the chr_fi...
Status: CLOSED DUPLICATE of bug 828375
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f0d3061d1d6b6fe600fde65e175...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:35 EDT by Nicolas Mailhot
Modified: 2012-06-04 15:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 15:51:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:35:12 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:23:03 CEST

description:
:SELinux is preventing /usr/sbin/rpcbind from read, write access on the chr_file null.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpcbind should be allowed read write access on the null chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpcbind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rpcbind_t:s0
:Target Context                system_u:object_r:default_t:s0
:Target Objects                null [ chr_file ]
:Source                        rpcbind
:Source Path                   /usr/sbin/rpcbind
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           rpcbind-0.2.0-16.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    lun. 04 juin 2012 19:17:39 CEST
:Last Seen                     lun. 04 juin 2012 19:17:39 CEST
:Local ID                      e02c99b4-e21e-43ac-a019-2c3667c72ffd
:
:Raw Audit Messages
:type=AVC msg=audit(1338830259.763:135): avc:  denied  { read write } for  pid=920 comm="rpcbind" name="null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=AVC msg=audit(1338830259.763:135): avc:  denied  { open } for  pid=920 comm="rpcbind" path="/dev/null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830259.763:135): arch=x86_64 syscall=open success=yes exit=EIO a0=7fb98172d835 a1=2 a2=0 a3=7fb9821c7a10 items=0 ppid=1 pid=920 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpcbind exe=/usr/sbin/rpcbind subj=system_u:system_r:rpcbind_t:s0 key=(null)
:
:Hash: rpcbind,rpcbind_t,default_t,chr_file,read,write
:
:audit2allow
:
:#============= rpcbind_t ==============
:#!!!! The source type 'rpcbind_t' can write to a 'chr_file' of the following types:
:# initrc_devpts_t, devtty_t, null_device_t, zero_device_t
:
:allow rpcbind_t default_t:chr_file { read write open };
:
:audit2allow -R
:
:#============= rpcbind_t ==============
:#!!!! The source type 'rpcbind_t' can write to a 'chr_file' of the following types:
:# initrc_devpts_t, devtty_t, null_device_t, zero_device_t
:
:allow rpcbind_t default_t:chr_file { read write open };
:
Comment 1 Daniel Walsh 2012-06-04 15:51:57 EDT

*** This bug has been marked as a duplicate of bug 828375 ***

Note You need to log in before you can comment on or make changes to this bug.