Bug 828392 - SELinux is preventing /usr/lib/cups/backend/usb from 'read' accesses on the chr_file 003.
SELinux is preventing /usr/lib/cups/backend/usb from 'read' accesses on the c...
Status: CLOSED DUPLICATE of bug 828375
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:94729d20eef16d763b9de9bca72...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:36 EDT by Nicolas Mailhot
Modified: 2012-06-04 15:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 15:53:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:36:55 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:24:54 CEST

description:
:SELinux is preventing /usr/lib/cups/backend/usb from 'read' accesses on the chr_file 003.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that usb should be allowed read access on the 003 chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep usb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:default_t:s0
:Target Objects                003 [ chr_file ]
:Source                        usb
:Source Path                   /usr/lib/cups/backend/usb
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           cups-1.5.3-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    lun. 04 juin 2012 18:39:47 CEST
:Last Seen                     lun. 04 juin 2012 19:17:40 CEST
:Local ID                      9ae0dd2d-34bb-40d1-8531-c30def70e735
:
:Raw Audit Messages
:type=AVC msg=audit(1338830260.443:147): avc:  denied  { read } for  pid=889 comm="usb" name="003" dev="devtmpfs" ino=1195 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=AVC msg=audit(1338830260.443:147): avc:  denied  { open } for  pid=889 comm="usb" path="/dev/bus/usb/001/003" dev="devtmpfs" ino=1195 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830260.443:147): arch=x86_64 syscall=open success=yes exit=EBADF a0=7fff224d57d0 a1=0 a2=7fff224d57e4 a3=7fff224d5508 items=0 ppid=755 pid=889 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=usb exe=/usr/lib/cups/backend/usb subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: usb,cupsd_t,default_t,chr_file,read
:
:audit2allow
:
:#============= cupsd_t ==============
:allow cupsd_t default_t:chr_file { read open };
:
:audit2allow -R
:
:#============= cupsd_t ==============
:allow cupsd_t default_t:chr_file { read open };
:
Comment 1 Daniel Walsh 2012-06-04 15:53:41 EDT

*** This bug has been marked as a duplicate of bug 828375 ***

Note You need to log in before you can comment on or make changes to this bug.