Bug 828397 - SELinux is preventing /usr/bin/perl from 'ioctl' accesses on the chr_file /dev/null.
SELinux is preventing /usr/bin/perl from 'ioctl' accesses on the chr_file /de...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7e62547193dd1a3c3b06de020a8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:38 EDT by Nicolas Mailhot
Modified: 2012-06-04 16:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 16:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:38:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:26:09 CEST

description:
:SELinux is preventing /usr/bin/perl from 'ioctl' accesses on the chr_file /dev/null.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/dev/null default label should be null_device_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /dev/null
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that perl should be allowed ioctl access on the null chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ddclient /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:ddclient_t:s0
:Target Context                system_u:object_r:default_t:s0
:Target Objects                /dev/null [ chr_file ]
:Source                        ddclient
:Source Path                   /usr/bin/perl
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           perl-5.14.2-217.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    lun. 04 juin 2012 19:17:40 CEST
:Last Seen                     lun. 04 juin 2012 19:17:40 CEST
:Local ID                      79089bcf-f74a-4e3a-a763-061be46a87c8
:
:Raw Audit Messages
:type=AVC msg=audit(1338830260.627:156): avc:  denied  { ioctl } for  pid=933 comm="ddclient" path="/dev/null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:ddclient_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830260.627:156): arch=x86_64 syscall=ioctl success=no exit=ENOTTY a0=0 a1=5401 a2=7fffd7f59230 a3=6471 items=0 ppid=1 pid=933 auid=4294967295 uid=474 gid=468 euid=474 suid=474 fsuid=474 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm=ddclient exe=/usr/bin/perl subj=system_u:system_r:ddclient_t:s0 key=(null)
:
:Hash: ddclient,ddclient_t,default_t,chr_file,ioctl
:
:audit2allow
:
:#============= ddclient_t ==============
:allow ddclient_t default_t:chr_file ioctl;
:
:audit2allow -R
:
:#============= ddclient_t ==============
:allow ddclient_t default_t:chr_file ioctl;
:
Comment 1 Daniel Walsh 2012-06-04 16:00:09 EDT
Duplicate of 828375

Note You need to log in before you can comment on or make changes to this bug.