Bug 8284 - Potential Linux 6.1 Adaptec SCSI driver problem with PPR messaging
Potential Linux 6.1 Adaptec SCSI driver problem with PPR messaging
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-07 19:06 EST by carl_j_white
Modified: 2007-04-18 12:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 13:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carl_j_white 2000-01-07 19:06:23 EST
The Linux SCSI interface driver "aic7xxx.c" may have a potential
problem with PPR (Parallel Protocol Request) messaging.
(SCSI Parallel Interface-3 specification T10/1302D,Rev 12,
 Section 16.3.10.1)
The driver attempts to send a PPR message but rejects the reply from the
target.  The driver detects that a SCSI-3 target is present and sends a PPR
message. However, it rejects the reply because the Adaptec SCSI card ID
does not indicate that PPR messaging is supported.
This problem only appears when the target supports PPR messaging and the
Adaptec SCSI interface card does not support PPR messaging.

Potential Solutions
Solution 1:
The driver should not send a PPR message if PPR messaging is not supported
by the Adaptec SCSI interface card present.  An alternate method of
negotiation should be attempted for Adaptec SCSI interface cards that do
not support PPR messaging.
aic7xxx.c, line 2944:
   change
      if ( (buffer[2] & SCSI_VERSION_BITS) == 3)
   to
      if (( (buffer[2] & SCSI_VERSION_BITS) == 3) &&
          (p->features & AHC_ULTRA3) )

Solution2:
Determine the Adaptec SCSI interface cards support PPR messaging and only
attempt PPR messaging when both the Adaptec SCSI interface card support PPR
messaging and the target supports PPR messaging.
Testing that has been performed on an Adaptec 2940U2W(AIC7890) appears to
support PPR messaging if the following 3 lines of code are removed from the
driver.
aic7xxx.c, line 5646-5649:
   /* p->features == 0x04F6 for the Adaptec 2940U2W */
   if( !(p->features & AHC_ULTRA3) )
   {
      reject = TRUE;
      break;
   }

Carl J. White III
Firmware Development Engineer
Seagate Technology
10323 West Reno Avenue
P.O. Box 12313
Oklahoma City, OK 73157
(405)577-3963
carl_j_white@notes.seagate.com
Comment 1 Stephen John Smoogen 2003-01-23 19:04:18 EST
There have been substantial changes in the Adaptec driver since the Red Hat
Linux 6.1 release. Does this problem still occur in 8.0/Phoebe betas?
Comment 2 Jay Turner 2003-04-14 13:59:31 EDT
Closing out due to bit-rot.

Note You need to log in before you can comment on or make changes to this bug.