This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 828404 - SELinux is preventing /usr/sbin/ip from 'read' accesses on the chr_file /dev/null.
SELinux is preventing /usr/sbin/ip from 'read' accesses on the chr_file /dev/...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:156c23155011e697a28dece70f6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:39 EDT by Nicolas Mailhot
Modified: 2012-06-04 16:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 16:00:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:39:25 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:27:33 CEST

description:
:SELinux is preventing /usr/sbin/ip from 'read' accesses on the chr_file /dev/null.
:
:*****  Plugin restorecon (93.9 confidence) suggests  *************************
:
:If you want to fix the label. 
:/dev/null default label should be null_device_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /dev/null
:
:*****  Plugin leaks (6.10 confidence) suggests  ******************************
:
:If you want to ignore ip trying to read access the null chr_file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/sbin/ip /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (1.43 confidence) suggests  ***************************
:
:If you believe that ip should be allowed read access on the null chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ip /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:ifconfig_t:s0
:Target Context                system_u:object_r:default_t:s0
:Target Objects                /dev/null [ chr_file ]
:Source                        ip
:Source Path                   /usr/sbin/ip
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           iproute-3.4.0-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    lun. 04 juin 2012 19:17:39 CEST
:Last Seen                     lun. 04 juin 2012 19:17:40 CEST
:Local ID                      ba6dac4e-049e-420f-a54a-856768a2126b
:
:Raw Audit Messages
:type=AVC msg=audit(1338830260.923:164): avc:  denied  { read } for  pid=969 comm="ip" path="/dev/null" dev="devtmpfs" ino=1033 scontext=system_u:system_r:ifconfig_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830260.923:164): arch=x86_64 syscall=execve success=yes exit=0 a0=cea050 a1=ce7c70 a2=cea430 a3=8 items=0 ppid=968 pid=969 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ip exe=/usr/sbin/ip subj=system_u:system_r:ifconfig_t:s0 key=(null)
:
:Hash: ip,ifconfig_t,default_t,chr_file,read
:
:audit2allow
:
:#============= ifconfig_t ==============
:allow ifconfig_t default_t:chr_file read;
:
:audit2allow -R
:
:#============= ifconfig_t ==============
:allow ifconfig_t default_t:chr_file read;
:
Comment 1 Daniel Walsh 2012-06-04 16:00:37 EDT
Duplicate of 828375

Note You need to log in before you can comment on or make changes to this bug.