Bug 828424 - SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the chr_file /dev/urandom.
SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the chr_f...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:08407f0c3176fd2a27e7501b9fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:43 EDT by Nicolas Mailhot
Modified: 2012-06-04 16:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 16:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2012-06-04 13:43:28 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-0.rc1.git0.1.fc18.x86_64
time:           lun. 04 juin 2012 19:32:02 CEST

description:
:SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the chr_file /dev/urandom.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/dev/urandom default label should be urandom_device_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /dev/urandom
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed getattr access on the urandom chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep pyzor /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:spamc_t:s0
:Target Context                system_u:object_r:default_t:s0
:Target Objects                /dev/urandom [ chr_file ]
:Source                        pyzor
:Source Path                   /usr/bin/python2.7
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-6.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-0.rc1.git0.1.fc18.x86_64 #1
:                              SMP Sun Jun 3 14:07:54 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    lun. 04 juin 2012 19:17:54 CEST
:Last Seen                     lun. 04 juin 2012 19:18:01 CEST
:Local ID                      4a7f4b5d-ef72-4b92-804f-ad2ecb5b0098
:
:Raw Audit Messages
:type=AVC msg=audit(1338830281.933:262): avc:  denied  { getattr } for  pid=1260 comm="pyzor" path="/dev/urandom" dev="devtmpfs" ino=1038 scontext=system_u:system_r:spamc_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338830281.933:262): arch=x86_64 syscall=fstat success=yes exit=0 a0=7 a1=7fff026b0610 a2=7fff026b0610 a3=0 items=0 ppid=1061 pid=1260 auid=4294967295 uid=490 gid=485 euid=490 suid=490 fsuid=490 egid=485 sgid=485 fsgid=485 tty=(none) ses=4294967295 comm=pyzor exe=/usr/bin/python2.7 subj=system_u:system_r:spamc_t:s0 key=(null)
:
:Hash: pyzor,spamc_t,default_t,chr_file,getattr
:
:audit2allow
:
:#============= spamc_t ==============
:allow spamc_t default_t:chr_file getattr;
:
:audit2allow -R
:
:#============= spamc_t ==============
:allow spamc_t default_t:chr_file getattr;
:
Comment 1 Daniel Walsh 2012-06-04 16:00:48 EDT
Duplicate of 828375

Note You need to log in before you can comment on or make changes to this bug.