Bug 828472 - [RFE] Allow for extensibility of a Standard Operating Environment template while maintaining the benefits of image based provisioning
[RFE] Allow for extensibility of a Standard Operating Environment template wh...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 14:58 EDT by james labocki
Modified: 2014-12-18 11:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-18 11:27:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-06-04 14:58:20 EDT
Description of problem:
A way to have extensibility of a Standard Operating Environment template while maintaining the benefits of image based provisioning. For example:
 - User defines templateW
 - User creates templateX(adds EAP), templateY(adds HTTPD), templateZ(add MySQLD) which inherits templateW properties
 - User builds images for templateW,X,Y,Z
 - User launches images.
 Note that launching images and then having them configured after the fact are not acceptable as it may take too much time (pulling EAP to 500 instances for example).
 Also Note: Copying and pasting from template to template is not scaleable because as soon as you change one in production, you will have to hunt down and change all of the other templates.
 Also Note: Configuration (e.g. changing httpd.con) is ok at first boot time, but installing EAP6 is not, because it can take significant time to put 1GB of content on the disk over the network from a repository, especially for multiple systems, but this is true for 1 or 500 systems
Comment 1 Bryan Kearney 2014-12-18 11:27:14 EST
We think this will be replaced by the docker work in 6.1, and improved promotion path work. Closing this out for now. If this was incorrect, please feel free to re-open with specific changes to the product. Thansk!

Note You need to log in before you can comment on or make changes to this bug.