Bug 828476 - [RFE] Provide example target_content.xml
[RFE] Provide example target_content.xml
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Ian McLeod
Rehana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 15:08 EDT by james labocki
Modified: 2012-12-04 10:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This enhancement provides an example 'target_content.xml' file in /usr/share/docs/imagefactory*/.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-06-04 15:08:40 EDT
This is a request for /usr/share/docs/imagefactory*/ to contain an example target_content.xml file
Comment 1 Ian McLeod 2012-09-11 18:57:52 EDT
A fix for this is currently brewing as imagefactory 1.0.2-1.
Comment 3 pushpesh sharma 2012-09-17 09:29:51 EDT
[root@dhcp201-113 ~]# cat /usr/share/doc/imagefactory-1.0.2/target_content.xml.example 
<template_includes>
  <include target='vsphere' os='Fedora' version='16' arch='x86_64'>
    <packages>
      <package name='faad2'/>
    </packages>
    <repositories>
      <repository name='rpmfusion-free'>
        <url>http://download1.rpmfusion.org/free/fedora/releases/16/Everything/x86_64/os/</url>
      </repository>
    </repositories>
  </include>
  <include target='rhevm' os='RHEL'>
    <packages>
      <package name='rhev-fedora-generic-package'/>
    </packages>
    <repositories>
      <repository name='rhev-repo'>
        <url>http://rhev.repo.com/</url>
      </repository>
    </repositories>
  </include>
</template_includes>



Verified on :-
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
[root@dhcp201-113 ~]#
Comment 4 james labocki 2012-09-20 20:57:40 EDT
Is it possible to include a version that shows examples for each provider and includes RHEL? Fedora and vsphere are great, but how would I know the target='rhevm' and not target='rhev'? Also, isn't there a minor version required for RHEL?
Comment 5 Dave Johnson 2012-11-02 14:24:40 EDT
I see it

[root@qeblade38 imagefactory]# rpm -qil imagefactory
Name        : imagefactory                 Relocations: (not relocatable)
Version     : 1.0.2                             Vendor: Red Hat, Inc.
Release     : 1.el6cf                       Build Date: Tue 11 Sep 2012 07:01:58 PM EDT
Install Date: Fri 02 Nov 2012 02:00:38 PM EDT      Build Host: x86-004.build.bos.redhat.com
Group       : Applications/System           Source RPM: imagefactory-1.0.2-1.el6cf.src.rpm
Size        : 780276                           License: ASL 2.0
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.aeolusproject.org/imagefactory.html
Summary     : System image generation tool
Description :


/usr/share/doc/imagefactory-1.0.2/target_content.xml.example
Comment 7 errata-xmlrpc 2012-12-04 10:10:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.