Bug 828488 - Slow loading of packages in eligible content menu
Slow loading of packages in eligible content menu
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 15:27 EDT by james labocki
Modified: 2014-09-18 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 16:00:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-06-04 15:27:24 EDT
Description of problem:
When a large amount of packages are included in a template (RHEL) the packages loaded fast, but when a small amount of packages are included the packages screen within the template never returns.

How reproducible:
Synchronize two custom repos (one with lots of packages, for example RHEL, and one with few packages, for example Zoo) then browse them in the eligible content in the system templates page.


Actual results:
Slow loading of small repos packages

Expected results:
Fast loading of small respos packages
Comment 2 Eric Helms 2012-09-10 12:12:21 EDT
I followed the steps above on Katello master as of bd2682aceee9f71256281652c08692fabf567f7a and was unable to reproduce.  All behaviors were as expected for both large and small repositories.  

- What version or hash of Katello did you encounter this with?

- Are you still able to re-produce?
Comment 3 Mike McCune 2012-09-10 16:00:13 EDT
CLOSING as fixed in upstream since we can't reproduce.  Feel free to re-open if this occurs in CFSE 1.1 or greater
Comment 4 Mike McCune 2013-08-16 14:23:10 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.