This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 828515 - [RFE] Verify aeolus-cleanup command should be run
[RFE] Verify aeolus-cleanup command should be run
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Steve Linabery
Rehana
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 16:12 EDT by james labocki
Modified: 2012-12-04 10:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This enhancement adds an 'Are you sure?' verification step to aeolus-cleanup command and a command line options -y|--assumeyes to force operation. If not provided, aeolus-cleanup prompts the user for confirmation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:10:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-06-04 16:12:35 EDT
Description of problem:
Add a 'Are you sure?' verification step to aeolus-cleanup command. It is to easy to remove everything. seriously.
Comment 2 Dave Johnson 2012-09-06 11:48:37 EDT
This should include specifing confirmation on the commandline with '-y'
Comment 4 Steve Linabery 2012-09-11 17:03:13 EDT
on master as 0b3dad6867fda2556376e17d0e420e7804a9be00
on 1.1 as 7ed26735ec17993c9d41281a7421ea5d904a078a
Comment 5 pushpesh sharma 2012-09-17 08:28:05 EDT
Verified on :

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch






[root@dhcp201-113 ~]# aeolus-cleanup -y
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Exec[remove_deltacloud_tmp_files]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Aeolus::Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: could not change directory to "/root"




[root@dhcp201-113 ~]# aeolus-cleanup 
aeolus-cleanup will delete local aeolus installations.
Are you sure you wish to proceed? [y/N]: y
notice: /File[/var/lib/aeolus-conductor]/ensure: removed
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[aeolus-conductor]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_aeolus_templates]/returns: executed successfully
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Service[deltacloud-core]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[ma
Comment 7 errata-xmlrpc 2012-12-04 10:10:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.