Bug 828563 - [abrt] kernel: WARNING: at sound/pci/hda/hda_intel.c:1632 azx_pcm_open+0x22d/0x297 [snd_hda_intel]()
[abrt] kernel: WARNING: at sound/pci/hda/hda_intel.c:1632 azx_pcm_open+0x22d/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:6e9fc98e67699b0a745b7441d4b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 17:50 EDT by Jose
Modified: 2012-06-04 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 19:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose 2012-06-04 17:50:42 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.0-7.fc16.i686 root=/dev/sda5
kernel:         3.1.0-7.fc16.i686
reason:         WARNING: at sound/pci/hda/hda_intel.c:1632 azx_pcm_open+0x22d/0x297 [snd_hda_intel]()
time:           dom 20 may 2012 01:36:18 CDT

backtrace:
:WARNING: at sound/pci/hda/hda_intel.c:1632 azx_pcm_open+0x22d/0x297 [snd_hda_intel]()
:Hardware name: P53G
:BUG? (!runtime->hw.formats)
:Modules linked in: fuse be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi fcoe libfcoe 8021q libfc scsi_transport_fc scsi_tgt garp stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_state nf_conntrack ip6_tables w83627ehf hwmon_vid coretemp snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc ppdev parport_pc via_rhine mii parport i2c_viapro microcode uinput ata_generic pata_acpi sata_via pata_via nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
:Pid: 1390, comm: pulseaudio Tainted: G        W   3.1.0-7.fc16.i686 #1
:Call Trace:
: [<c046a79e>] ? print_modules+0x1/0x9f
: [<c043c959>] warn_slowpath_common+0x7c/0x91
: [<f7d791eb>] ? azx_pcm_open+0x22d/0x297 [snd_hda_intel]
: [<f7d791eb>] ? azx_pcm_open+0x22d/0x297 [snd_hda_intel]
: [<c043c9f9>] warn_slowpath_fmt+0x33/0x35
: [<f7d791eb>] azx_pcm_open+0x22d/0x297 [snd_hda_intel]
: [<f7cea8ff>] snd_pcm_open_substream+0x56/0xb1 [snd_pcm]
: [<c080f52f>] ? _cond_resched+0xd/0x21
: [<f7ceaa16>] snd_pcm_open+0xbc/0x1bd [snd_pcm]
: [<c0435caa>] ? try_to_wake_up+0x169/0x169
: [<f7c7d07d>] ? snd_lookup_minor_data+0x3e/0x45 [snd]
: [<f7ceab86>] snd_pcm_playback_open+0x34/0x3a [snd_pcm]
: [<f7c7d569>] snd_open+0x113/0x15a [snd]
: [<c05c4144>] ? kobject_get+0x12/0x17
: [<c04ee2c9>] chrdev_open+0xe9/0x10d
: [<c04e9b0b>] __dentry_open+0x15b/0x256
: [<c04ea981>] nameidata_to_filp+0x52/0x5e
: [<c04ee1e0>] ? cdev_put+0x1f/0x1f
: [<c04f55d9>] do_last+0x416/0x52b
: [<c04f57c4>] path_openat+0xac/0x283
: [<c04f59e5>] do_filp_open+0x2b/0x6c
: [<c05cc50e>] ? strncpy_from_user+0x34/0x4e
: [<c04fdc6e>] ? alloc_fd+0x53/0xbf
: [<c04ea9ec>] do_sys_open+0x5f/0xe5
: [<c047ee9f>] ? audit_syscall_entry+0x128/0x14a
: [<c04eaa98>] sys_open+0x26/0x2c
: [<c0810b0c>] syscall_call+0x7/0xb

comment:
:I was troubleshooting the reason of why I have NO analog output in my system. 
:
:I did: 
:
: aplay -D hw:0 /usr/share/sounds/startup3.wav
:
:Then ABRT showed up  with this problem.
:
:I have a VT1708/A HDA Intel sound chip, and in most of the times I have NO analog output for this chip when I start Fedora, and that is the only kind of output I phisically have on my computer, because this chip support the digital output as well, but I don't have a physical output for it, so If the system does not recognize or whatever it does to give me an analog output, then I have no sound, because I have no way to hear sound from the digital output. 
:
:I know that this kind of chips depends on the BIOS settings, so if I have a broken BIOS then I have problems with this sound chip, but I usually fix the no-sound problem reseting my BIOS, but here in Fedora it does not matter what I do with my BIOS, I don't have an analog output as well, when I don't have sound/incomplete outputs I have this error, that is almost always. 
:
:In Debian I have always at startup a working analog output, I can say the same in Ubuntu, but in Ubuntu there a few time when I don't, with Fedora I have a working analog output by a few times. 

smolt_data:
:
:
:General
:=================================
:UUID: 1bdafd4e-6e28-4822-982c-449db58b9e37
:SO: Fedora release 16 (Verne)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_MX.utf8
:Plataforma: i686
:BogoMIPS: 3990.49
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Intel(R) Celeron(R) D CPU        440  @ 2.00GHz
:Paso del UCP: 1
:Familia de UCP: 6
:Número de Modelo de CPU: 22
:Número de CPUs: 1
:Velocidad del CPU: 2000
:Memoria del Sistema: 3025
:Intercambio (swap) del Sistema: 2047
:Vendedor: PCCHIPS
:Sistema: P53G 1.0
:Factor de forma: Desktop
:Kernel: 3.1.0-7.fc16.i686
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(4358:13170:4121:6983) pci, None, PCI/ISA, VT8237S PCI to ISA Bridge
:(4358:12548:4121:6983) pci, ehci_hcd, USB, USB 2.0
:(4358:12344:4121:6983) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:12344:4121:6983) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:12344:4121:6983) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:10366:4358:13182) pci, None, HOST/PCI, VT8251 Ultra VLINK Controller
:(4358:9060:4358:9060) pci, None, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:13156:0:0) pci, None, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:868:4358:868) pci, agpgart-via, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:4964:4358:4964) pci, None, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:25444:4358:25444) pci, None, HOST/PCI, CN896/VN896/P4M900 Security Device
:(4358:29540:0:0) pci, None, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:17252:4358:17252) pci, None, HOST/PCI, CN896/VN896/P4M900 Host Bridge
:(4358:45464:0:0) pci, None, PCI/PCI, VT8237/VX700 PCI Bridge
:(4318:467:6618:20481) pci, nouveau, VIDEO, G72 [GeForce 7300 SE/7200 GS]
:(4358:21348:4358:21348) pci, None, BASE, CN896/VN896/P4M900 I/O APIC Interrupt Controller
:(4358:12936:4121:6983) pci, snd_hda_intel, MULTIMEDIA, VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
:(4358:41828:4358:49955) pci, pcieport, PCI/PCI, CN896/VN896/P4M900 PCI to PCI Bridge Controller
:(4358:50020:4358:49955) pci, pcieport, PCI/PCI, CN896/VN896/P4M900 PCI to PCI Bridge Controller
:(4358:13179:0:0) pci, None, HOST/PCI, VT8237A Host Bridge
:(4358:12344:4121:6983) pci, uhci_hcd, USB, VT82xxxxx UHCI USB 1.1 Controller
:(4358:12389:4121:258) pci, via-rhine, ETHERNET, VT6102 [Rhine-II]
:(4358:21362:4121:6983) pci, sata_via, STORAGE, N/A
:(4358:1393:4121:6983) pci, pata_via, STORAGE, VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda5 / ext4 4096 4096 2838332 1820241 1791414 720896 580582 580582
:/dev/sda6 /home ext3 4096 4096 8017672 5906054 5498808 2027856 1937975 1937975
:
Comment 1 Josh Boyer 2012-06-04 19:57:18 EDT
3.1.0-7 is fairly old.  Please update and open a new bug if you still see this.

Note You need to log in before you can comment on or make changes to this bug.