Bug 828576 - [ta_IN] failed pofilter filepathss tests for subscription-manager translations
[ta_IN] failed pofilter filepathss tests for subscription-manager translations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Adrian Likins
Entitlement Bugs
: i18n, Reopened, Translation
: 829498 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-04 18:16 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:46:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-04 18:16:06 EDT
Description of problem:
The gnome filepaths were not properly translated for 'ta_IN' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t filepaths /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-03-20 02:59-0400\n"
"Last-Translator: ifelix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."

Actual results:
Shown above

Expected results:

msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க 

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#filepaths
Comment 4 Sharath Dwaral 2012-06-06 18:08:28 EDT
*** Bug 829498 has been marked as a duplicate of this bug. ***
Comment 5 Sharath Dwaral 2012-06-07 10:22:18 EDT
The english msgid is correct and this is not the issue.

The msgstr in 'ta_IN' (tamil) language has the filepath in the begining of the sentence and it is followed by a hyphen (-) which should not be there because it neither is a part of the file path nor is it a valid character in the language. The hyphen should be replaced by a space.

msgstr "/etc/sysconfig/rhn/install-num-இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."

Should be : 

msgstr "/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."
Comment 6 Bryan Kearney 2012-06-07 15:33:36 EDT
From master:

[bkearney@bkearney po]$ pofilter --gnome -t filepaths ta.po 
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-04-26 12:16-0400\n"
"PO-Revision-Date: 2011-04-01 03:35-0400\n"
"Last-Translator: I Felix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
#: ../src/install-num-migrate-to-rhsm:107
msgid ""
"Could not read installation number from /etc/sysconfig/rhn/install-num.  "
"Aborting."
msgstr ""
"/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை."
"  அகற்றுகிறது."
[###########################################] 100%
[bkearney@bkearney po]$ 


No hyphen.
Comment 7 Sharath Dwaral 2012-07-12 18:27:15 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Steps:

# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po

# pofilter --gnome -t filepaths /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.poprocessing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2011-04-01 03:35-0400\n"
"Last-Translator: I Felix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."
[###########################################] 100%

Actual Result:
As shown above

Expected Result:

msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."

'-' hyphen should be removed after filepath in msgstr

Moving bug back to NEW
Comment 8 Shantha kumar 2012-07-24 02:58:34 EDT
//The gnome filepaths were not properly translated for 'ta_IN' language.//

Bug fixed. Thanks
Comment 9 Ankit Patel 2012-07-24 04:23:27 EDT
A fix can be found from: https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.0.X

Thanks Shantha.

/Ankit
Comment 10 Adrian Likins 2012-08-02 13:31:48 EDT
commit b55f33f5c1ba95129c3938e0ffb0181314fa985f
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Aug 1 16:25:13 2012 -0400

    843113: latest strings from zanata
    
    829495,829494,828954,828576,825393,825367
Comment 11 Sharath Dwaral 2012-08-03 10:32:30 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.12-1.git.6.1cb2247.el5
subscription-manager-1.0.12-1.git.6.1cb2247.el5
subscription-manager-firstboot-1.0.12-1.git.6.1cb2247.el5
python-rhsm-1.0.4-1.git.7.47e5112.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-gui-1.0.12-1.git.6.1cb2247.el5


Verification:

# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po

# pofilter --gnome -t filepaths /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ta_IN\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-08-01 16:16-0400\n"
"PO-Revision-Date: 2012-07-23 04:21-0400\n"
"Last-Translator: Shantha kumar <shkumar@redhat.com>\n"
"Language-Team: American English <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num இலிருந்து நிறுவல் எண்ணை வாசிக்க முடியவில்லை.  அகற்றுகிறது."
[###########################################] 100%


result is a false negative. (Because of the period at the end of filepath)

Moving bug to VERIFIED
Comment 12 Bryan Kearney 2013-01-09 12:46:11 EST
Batch change of verified bugs which must have missed making the errata.

Note You need to log in before you can comment on or make changes to this bug.