Bug 828579 - [ml] failed pofilter filepathss tests for subscription-manager translations
[ml] failed pofilter filepathss tests for subscription-manager translations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Reopened, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-04 18:21 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:46:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-04 18:21:06 EDT
Description of problem:
The gnome filepaths were not properly translated for 'ml' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ml/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t filepaths /usr/share/locale/ml/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ml\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-11 06:54-0400\n"
"Last-Translator: anipeter <anipeter@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: ml\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num-ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."

Actual results:
Shown above

Expected results:

msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#filepaths
Comment 4 Sharath Dwaral 2012-06-07 10:20:40 EDT
The english msgid is correct and this is not the issue.

The msgstr in 'ml' (malayalam) language has the filepath in the begining of the sentence and it is followed by a hyphen (-) which should not be there because it neither part of the file path nor is it a valid character in the language. The hyphen should be replaced by a space.

msgstr "/etc/sysconfig/rhn/install-num-ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."

Should be : 

msgstr "/etc/sysconfig/rhn/install-num ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."
Comment 5 Bryan Kearney 2012-06-07 15:32:42 EDT
This is what I get in master

[bkearney@bkearney po]$ pofilter --gnome -t filepaths ml.po 
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ml\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-04-26 12:16-0400\n"
"PO-Revision-Date: 2012-04-11 07:17-0400\n"
"Last-Translator: anipeter <anipeter@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: ml\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
#: ../src/install-num-migrate-to-rhsm:107
msgid ""
"Could not read installation number from /etc/sysconfig/rhn/install-num.  "
"Aborting."
msgstr ""
"/etc/sysconfig/rhn/install-num ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ "
"ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."
[###########################################] 100%


Plese note, there is no hyphen.
Comment 6 Sharath Dwaral 2012-06-12 13:23:40 EDT
# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

Steps to Reproduce:

# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ml/LC_MESSAGES/rhsm.po
# pofilter --gnome -t filepaths /usr/share/locale/ml/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ml\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-04-26 12:16-0400\n"
"PO-Revision-Date: 2012-06-08 08:15-0400\n"
"Last-Translator: anipeter <anipeter@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: ml\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num ല്‍ നിന്നും ഇന്‍സ്റ്റലേഷന്‍ നംബര്‍ ലഭ്യമാക്കുവാന്‍ സാധ്യമായില്ല. നിര്‍ത്തുന്നു."
[###########################################] 100%

Filepath in the translated string no longer has a hyphen at the end.  All significant issues are fixed.

Moving Bug to Verified.
Comment 7 Bryan Kearney 2013-01-09 12:46:07 EST
Batch change of verified bugs which must have missed making the errata.

Note You need to log in before you can comment on or make changes to this bug.