Bug 828583 - [ko] failed pofilter filepathss tests for subscription-manager translations
[ko] failed pofilter filepathss tests for subscription-manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-04 18:32 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-04 18:32:24 EDT
Description of problem:
The gnome filepaths were not properly translated for 'ko' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/ko/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ko/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t filepaths /usr/share/locale/ko/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ko\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-11 12:17-0400\n"
"Last-Translator: eukim <eukim@fedoraproject.org>\n"
"Language-Team: <ko@li.org>\n"
"Language: ko\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num에서 설치 번호를 읽을 수 없습니다. 중지 중 "

Actual results:
Shown above

Expected results:

msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num 에서 설치 번호를 읽을 수 없습니다. 중지 중 "

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#filepaths
Comment 2 Bryan Kearney 2012-06-06 07:27:35 EDT
Can fix all but one. The one with a trailing dot is  false negative due to sentence structure.
Comment 4 Sharath Dwaral 2012-06-12 13:58:42 EDT
# rpm -q subscription-manager
subscription-manager-1.0.3-1.git.49.da029ad.el6.x86_64

Steps to Reproduce:

# msgunfmt --no-wrap /usr/share/locale/ko/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ko/LC_MESSAGES/rhsm.po
# pofilter --gnome -t filepaths /usr/share/locale/ko/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: ko\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-04-26 12:16-0400\n"
"PO-Revision-Date: 2012-04-10 09:51-0400\n"
"Last-Translator: eukim <eukim@fedoraproject.org>\n"
"Language-Team: <ko@li.org>\n"
"Language: ko\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) filepaths: Different file paths
msgid "Could not read installation number from /etc/sysconfig/rhn/install-num.  Aborting."
msgstr "/etc/sysconfig/rhn/install-num 에서 설치 번호를 읽을 수 없습니다. 중지 중 "
[###########################################] 100%


Filepath in the translated string has a space at the end.  All significant issues are fixed.

Moving Bug to Verified.
Comment 5 RHEL Product and Program Management 2012-06-19 14:28:24 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 8 errata-xmlrpc 2013-01-07 22:53:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.