Bug 828592 - cannot create Volume Group names longer than 16 characters
cannot create Volume Group names longer than 16 characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 19:50 EDT by Gerry Reno
Modified: 2012-09-12 11:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 11:50:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Reno 2012-06-04 19:50:22 EDT
Description of problem:
You cannot edit the Volume Group name field.  I need several Volume Groups but now I have no way
to do this since there's no way to make them unique.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot from F17 x86_64 DVD
2. Select Custom Partitioning
3. Create a Physical Volume
4. Create a Volumne Group
5. Create another Physical Volume
6  Create a 2nd Volume Group
  
Actual results:
The installer will not allow you to edit the name of the Volume Group.
This results in inability to create more than 1 Volume Group.

Expected results:
Able to edit Volume Group name field.

Additional info:
Comment 1 Gerry Reno 2012-06-04 23:55:59 EDT
Came back to this and found that the problem was rooted in anaconda restricting the Volume Group names to only 16 characters.

Our machine names are all 13 characters long and when you add vg_ as prefix the Volume Group default name presented is already 16 characters long.  This made it appear like you could not edit the field.

On previous installations we have Volume Group names that are much longer than 16 characters.

The Volume Group name field should not be so narrowly restricted.

.
Comment 2 David Lehman 2012-06-05 11:16:19 EDT
The code that limits the length of input to these text entries (vgname, lvname) to 16 characters has been there for more than 10 years. Your only option for using longer names is kickstart.

This length limitation will not be present in F18.
Comment 3 Gerry Reno 2012-06-05 13:09:25 EDT
Maybe that's how these machines got the longer Volume Group names because we installed all our servers using kickstart.

Another problem is see with names is this:

I enter a VG name:  vg_renog11-1

When it gets created it looks like this:  /dev/mapper/vg_renog11--1-lv00

Why does the installer always add extra hyphen?

.
Comment 4 David Lehman 2012-06-05 14:39:16 EDT
(In reply to comment #3)
> I enter a VG name:  vg_renog11-1
> 
> When it gets created it looks like this:  /dev/mapper/vg_renog11--1-lv00
> 
> Why does the installer always add extra hyphen?

lvm (or device-mapper) does that. They have to escape the dash since the dash has special meaning for lvm device names (delineating vg name from lv name).

Note You need to log in before you can comment on or make changes to this bug.