Bug 828625 - Unicode decode error in /var/log/messages
Unicode decode error in /var/log/messages
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On: 748753
Blocks: 767775 773757
  Show dependency treegraph
 
Reported: 2012-06-05 00:28 EDT by Caspar Zhang
Modified: 2015-02-08 16:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 748753
Environment:
Last Closed: 2013-02-01 13:20:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
controller patch fixing error message printing (508 bytes, patch)
2012-08-28 09:53 EDT, Greg Nichols
czhang: review+
Details | Diff

  None (edit)
Description Caspar Zhang 2012-06-05 00:28:11 EDT
Guangze find that the fix is incomplete:

"

From yesterday's v7 info job, this bug is also seen even if not setting --debug:

https://beaker.engineering.redhat.com/jobs/242814
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2012/06/2428/242814/516969/6120540/32856054/test_log-v7-info-GPL_UNSIGNED.log
(at the bottom)

This is the patch already checked in R32:
https://bugzilla.redhat.com/attachment.cgi?id=570607&action=diff

except UnicodeDecodeError, error: 
    if self.debug != Constants.off:
        print "Warning: Unicode decode error in %s" % syslog
    print error <--- still printing this error msg
    # if we can't decode it, skip the whole line
    continue

"

Seems missing a indention above. I don't think this will blocker 1.5, let's push to next version.

+++ This bug was initially created as a clone of Bug #748753 +++

Description of problem:

https://hardware.redhat.com/results.cgi?cert_id=709613&id=231345

reboot took 00:03:00
method: reboot
kernel: 2.6.32-71.el6.x86_64
Warning: Unicode decode error in /var/log/messages
'ascii' codec can't decode byte 0xd2 in position 98: ordinal not in range(128)
Warning: Unicode decode error in /var/log/messages
'ascii' codec can't decode byte 0xd2 in position 98: ordinal not in range(128)
Warning: Unicode decode error in /var/log/messages
[repeating]

This could also be seen in other tests, not only kdump.

Guangze/HWCERT team, can we find a stable reproducer?

--- Additional comment from gnichols@redhat.com on 2012-01-19 03:25:34 CST ---

This warnings are innocuous - we'll change it so they only appear if --debug is set.

--- Additional comment from rlandry@redhat.com on 2012-03-16 06:17:34 CST ---

This looks like it should stay on 1.5 but is not a blocker.

--- Additional comment from gnichols@redhat.com on 2012-03-16 21:18:47 CST ---

Created attachment 570607 [details]
controller patch adding debug setting, disabling warning when debug is off

--- Additional comment from gnichols@redhat.com on 2012-03-16 21:19:20 CST ---

Created attachment 570608 [details]
hardware test patch passing debug to controller base class

--- Additional comment from gnichols@redhat.com on 2012-03-17 00:38:28 CST ---

Committed to R9

--- Additional comment from errata-xmlrpc@redhat.com on 2012-03-28 04:42:16 CST ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2012:13044-01
http://errata.devel.redhat.com/errata/show/13044

--- Additional comment from czhang@redhat.com on 2012-04-10 23:25:03 CST ---

verified in R18

--- Additional comment from czhang@redhat.com on 2012-06-04 15:25:24 CST ---


    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An enhancement has been made in v7 1.5 that the following Unicode decode error warning message will be no more displayed unless --debug is set:

    Warning: Unicode decode error in /var/log/messages
    'ascii' codec can't decode byte 0xd2 in position 98: ordinal not in range(128)
    Warning: Unicode decode error in /var/log/messages
    'ascii' codec can't decode byte 0xd2 in position 98: ordinal not in range(128)
Comment 1 Greg Nichols 2012-08-28 09:53:35 EDT
Created attachment 607533 [details]
controller patch fixing error message printing
Comment 6 errata-xmlrpc 2013-02-01 13:20:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.