Bug 828629 - Loading and Searching indicators are shown when the relevant view is not visible
Loading and Searching indicators are shown when the relevant view is not visible
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
low Severity low
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 01:01 EDT by David Mason
Modified: 2012-11-07 01:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20121018-0932)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:18:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-06-05 01:01:16 EDT
Description of problem:
When a document is being loaded and the document view is not visible, the loading indicator is still show. When a project-wide search is run and the search page is not visible, the searching indicator is still shown.

This is most likely to be observed when navigating using history.


Version-Release number of selected component (if applicable):
1.6

How reproducible:
Always

Steps to Reproduce:
1.Open translation editor for a project-iteration with multiple documents
2.Click one document to load it in the editor
3.Click "search and replace"
4.Enter a search phrase that is found in another document
5.Click "view in editor" for any document that is not loaded
6.Copy the URL to use in step 8
7.Use browser "back"
8.Paste the copied URL in a different browser tab or window and navigate to it
  
Actual results:
7. "Loading..." is shown over the search results
8. both "Searching.." and "Loading..." are shown (overlapping) over document view

Expected results:
7. "Loading..." not shown when document view is not visible
8. "Searching..." not shown when search view is not visible

Additional info:
Comment 1 Alex Eng 2012-10-02 18:44:25 EDT
Implement singleton on loading panel to avoid conflicting between editor and search replace.

See 
https://github.com/zanata/zanata/commit/6b634897807fdcad1f93b43ba4cd28cf8e406d84
https://github.com/zanata/zanata/commit/ae6e32ff7b772c1309161b67a7304b884213dcd4

However, there's possibility that "Loading..." will display in search replace view if browser's back is click while loading in editor.
Comment 2 Alex Eng 2012-10-03 19:24:53 EDT
Ignore last comment on the possibility of this error being occur when back button is clicked. Further testing show problem has been solved with implementation above.
Comment 3 Ding-Yi Chen 2012-10-11 20:36:19 EDT
Tested with Zanata version 1.8.0-SNAPSHOT (20121012-0031)
"Searching" is still appear if you paste the URL to other browser.

Reassigned.
Comment 4 Alex Eng 2012-10-14 21:15:26 EDT
Implemented fix. Change of loading panel to be common between searching and loading since the process is necessary before any activities is taken.

See https://github.com/zanata/zanata/commit/edc8a8a29e78b89a12c03623bd4419602c37a937
Comment 5 Ding-Yi Chen 2012-10-17 20:30:18 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20121018-0932)
Comment 6 Sean Flanigan 2012-11-07 01:18:23 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.