Bug 828701 - rename failures with multiple clients
rename failures with multiple clients
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: stat-prefetch (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Anand Avati
Anush Shetty
: Triaged
: 852577 858486 (view as bug list)
Depends On:
Blocks: 852577 858486
  Show dependency treegraph
 
Reported: 2012-06-05 04:26 EDT by Anush Shetty
Modified: 2015-09-01 19:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852577 (view as bug list)
Environment:
Last Closed: 2012-11-07 07:23:06 EST
Type: Bug
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-06-05 04:26:45 EDT
Description of problem: With 2 fuse clients, trying to rename a directory from 2nd  client and then renaming it back to the old name from the 1st client fails. 

mkdir -p /mnt/gluster1/h1;
mv /mnt/gluster2/h1 /mnt/gluster2/h2;
mv /mnt/gluster1/h2 /mnt/gluster/h1;


Ran this script in a loop, and was able to reproduce it easily


Version-Release number of selected component (if applicable): 3.3.0qa45


How reproducible: Often

  
Actual results:

Rename fails with ENOENT 


Expected results:

Shouldn't error out


Additional info:

By mounting the fuse client with --entry-timeout=0 and --attribute-timeout=0 and setting the md-cache timeout to 0, this issue wasn't seen.
Comment 1 Amar Tumballi 2012-10-23 07:30:48 EDT
Avati any update on this? I would say this is expected behavior in case where the parameters 'entry-timeout' 'attribute-timeout' and md-cache xlator are present... Let me know what you think about this?
Comment 2 Anand Avati 2012-11-05 21:09:42 EST
Yes, this is expected behavior. Let's close this as not a bug.
Comment 3 Amar Tumballi 2012-11-07 07:24:10 EST
*** Bug 852577 has been marked as a duplicate of this bug. ***
Comment 4 Amar Tumballi 2012-11-07 07:24:45 EST
*** Bug 858486 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.