Bug 828708 - Broken API Javadoc link on 'Help-->API Javadoc'
Broken API Javadoc link on 'Help-->API Javadoc'
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
unspecified
All Linux
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Deon Ballard
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 04:50 EDT by Jeeva Kandasamy
Modified: 2012-06-21 19:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 19:17:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeeva Kandasamy 2012-06-05 04:50:12 EDT
Description of problem:
Broken API Javadoc link on 'Help-->API Javadoc'

Version-Release number of selected component (if applicable):
JBoss Operations Network
Version: 3.1.0.CR2
Build Number: 05c820d:aaa5a79
GWT Version: 2.4.0
SmartGWT Version: 3.0

How reproducible:
always

Steps to Reproduce:
1.Logon to JON
2.Navigate to 'Help-->API javadoc'
3.says
-----------------------
Not Found

The requested URL /docs/en-US/JBoss_Operations_Network/3.1/html/API/index.html was not found on this server.
Apache Server at docs.redhat.com Port 80
-----------------------
Comment 1 Deon Ballard 2012-06-06 15:09:46 EDT
Yes, this is expected. The only doc I haven't generated yet for testing is the API. I will try to build and push that today/tomorrow, but I think this is not a bug (or won't be for GA).
Comment 2 Deon Ballard 2012-06-08 13:08:24 EDT
It's live right now; hopefully, the help links should work now.

Real link:
http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.1/html/API/index.html
Comment 3 Jeeva Kandasamy 2012-06-11 05:27:59 EDT
Verified on:
JBoss Operations Network
Version: 3.1.0.GA
Build Number: b575169:a53e41e
GWT Version: 2.4.0
SmartGWT Version: 3.0
Comment 4 Deon Ballard 2012-06-21 19:17:08 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.