Bug 828721 - ovirt-engine-backend: wrong error when trying to remove a template disk from the disk tab
ovirt-engine-backend: wrong error when trying to remove a template disk from ...
Status: CLOSED DUPLICATE of bug 833420
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 05:14 EDT by Dafna Ron
Modified: 2016-02-10 12:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 10:18:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (25.54 KB, application/x-xz)
2012-06-05 05:14 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-05 05:14:13 EDT
Created attachment 589445 [details]
log

Description of problem:

trying to remove a template disk from the disk tab will give the following error: 

Error: Cannot remove Virtual Machine Disk. Provided wrong storage domain, which is not related to disk.

2012-06-02 12:08:09,427 WARN  [org.ovirt.engine.core.bll.RemoveDiskCommand] (http--0.0.0.0-8080-4) CanDoAction of action RemoveDisk failed. Reasons:VAR__ACTION__REMOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_STOARGE_DOMAIN_IS_WRONG



Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. try to remove a template disk from the disk tab
2.
3.
  
Actual results:

we cannot remove disk with incorrect error

Expected results:

we should get a correct CanDoAction

Additional info:
Comment 1 Asaf Shakarchi 2012-07-04 10:18:27 EDT

*** This bug has been marked as a duplicate of bug 833420 ***

Note You need to log in before you can comment on or make changes to this bug.