Bug 828808 - Errai: Detect multiple marshalling definition collisions
Errai: Detect multiple marshalling definition collisions
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai (Show other bugs)
2.0.0.ER7
Unspecified Unspecified
medium Severity medium
: ---
: 2.0.0.ER8
Assigned To: Pavel SLegr
Karel Piwko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 08:19 EDT by Karel Piwko
Modified: 2012-10-19 16:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL6 64bits
Last Closed: 2012-06-22 03:32:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete junit report. (588.94 KB, text/xml)
2012-06-05 08:19 EDT, Karel Piwko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ERRAI-316 None Closed Errai marshalling must detect mapping definition collisions 2012-10-19 16:08:19 EDT

  None (edit)
Description Karel Piwko 2012-06-05 08:19:56 EDT
Created attachment 589514 [details]
Complete junit report.

Description of problem:

Execution of integration tests from Errai sources fails with 70 errors. 
These errors can be divided into two packages:

* org.jboss.errai.bus.client.tests.SerializationTests
* org.jboss.errai.cdi.rpc.client.test.RpcIntegrationTest

Full log attached. Further analysis:

All the issues seems to be caused by following exception:

Caused by: java.lang.IllegalStateException: Already finished
...

I guess this is execution problem, so marking as medium severity. Please let me know if my configuration has to be changed.

Note: executed via:

mvn -Pintegration-test
clean
verify
-Dorg.jboss.errai.bus.do_long_poll=false
-Dmaven.test.failure.ignore=true
-s /home/kpiwko/devel/wfk/wfk-tools/settings.xml
Comment 1 Karel Piwko 2012-06-07 04:48:34 EDT
I updated job execution as Christian suggested. I'm still not able to get a clean run though, experiencing exception shown above:

java.lang.IllegalStateException: Already finished
	at org.jboss.errai.common.client.api.tasks.ClientTaskManager$ClientAsyncTask.finishUp(ClientTaskManager.java:140)
	at org.jboss.errai.common.client.api.tasks.ClientTaskManager$ClientAsyncTask.cancel(ClientTaskManager.java:115)
	at org.jboss.errai.common.client.api.extension.InitVotes.beginInit(InitVotes.java:201)
	at org.jboss.errai.common.client.api.extension.InitVotes.waitFor(InitVotes.java:108)
	at org.jboss.errai.common.client.api.extension.InitVotes.waitFor(InitVotes.java:98)
	at org.jboss.errai.bus.client.framework.ClientMessageBusImpl.registerInitVoteCallbacks(ClientMessageBusImpl.java:720)
	at org.jboss.errai.bus.client.framework.ClientMessageBusImpl.init(ClientMessageBusImpl.java:738)
	at org.jboss.errai.bus.client.tests.AbstractErraiTest.gwtSetUp(AbstractErraiTest.java:97)
	at org.jboss.errai.ioc.client.test.AbstractErraiIOCTest.gwtSetUp(AbstractErraiIOCTest.java:29)
Comment 2 Christian Sadilek 2012-06-07 13:05:33 EDT
This is a good catch and helped us identify an intermittent problem. It should be fixed now.

JIRA: https://issues.jboss.org/browse/ERRAI-316

Commit: https://github.com/errai/errai/commit/4fc7c45131bd499fa3e494821a798a61d6e2a75c
Comment 4 Karel Piwko 2012-06-13 07:10:06 EDT
Verified execution in ER8 no longer spawns this problem.
Comment 6 JBoss JIRA Server 2012-10-19 16:08:19 EDT
Christian Sadilek <csadilek@redhat.com> updated the status of jira ERRAI-316 to Closed

Note You need to log in before you can comment on or make changes to this bug.