This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 828903 - [bn_IN] failed pofilter options tests for subscription-manager translations
[bn_IN] failed pofilter options tests for subscription-manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-05 10:55 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-05 10:55:03 EDT
Description of problem:
The gnome options were not properly translated for 'bn_IN' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t options /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-13 02:03-0400\n"
"Last-Translator: runab <runab@redhat.com>\n"
"Language-Team: Bengali (India) <anubad@lists.ankur.org.in>\n"
"Language: bn-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) options: Missing or translated option '--pool'
msgid "Error: This command requires that you specify a pool with --pool or use --auto."
msgstr "ত্রুটি: এই কমান্ডের ক্ষেত্রে -pool সহযোগে একটি পুল উল্লেখ করা অথবা --auto ব্যবহার করা আবশ্যক।"


Actual results:
Shown above

Expected results:

msgid "Error: This command requires that you specify a pool with --pool or use --auto."
msgstr "ত্রুটি: এই কমান্ডের ক্ষেত্রে --pool সহযোগে একটি পুল উল্লেখ করা অথবা --auto ব্যবহার করা আবশ্যক।"

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#options
Comment 3 Alex Wood 2012-06-18 11:30:01 EDT
commit 34b34df7e5cee4759f4f11c68491c5eb54e7529c
Refs: subscription-manager-1.0.2-1-95-g34b34df
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Wed Jun 6 07:16:47 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Wed Jun 6 15:38:40 2012 -0400

    828903: Fix translation of options in the bn po file.
Comment 4 RHEL Product and Program Management 2012-06-18 11:47:44 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Runa Bhattacharjee 2012-06-27 05:31:40 EDT
Now fixed for all the following versions listed on Zanata:

0.99.X
0.98.X
0.97.X
1.0.X
Comment 7 Sharath Dwaral 2012-07-12 15:49:59 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Steps:

# msgunfmt --no-wrap /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po

# pofilter --gnome -t options /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po

processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2012-07-04 07:11-0400\n"
"Last-Translator: runab <runab@redhat.com>\n"
"Language-Team: Bengali (India) <anubad@lists.ankur.org.in>\n"
"Language: bn-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) options: Missing or translated option '--password'
msgid "Error: you must register or specify --username and --password to list service levels"
msgstr "ত্রুটি: পরিসেবা স্তরের তালিকা প্রদর্শনপর জন্য নিবন্ধন করা অথবা --username ও --পাসওয়ার্ড উল্লেখ করা আবশ্যক।"
[###########################################] 100%

Actual Result: 
As shown above

Expected Result:
msgid "Error: you must register or specify --username and --password to list service levels"
msgstr "ত্রুটি: পরিসেবা স্তরের তালিকা প্রদর্শনপর জন্য নিবন্ধন করা অথবা --username ও --পাসওয়ার্ড উল্লেখ করা আবশ্যক।"

--password should not be translated into native language

FailedQA
Comment 8 Runa Bhattacharjee 2012-07-13 02:08:04 EDT
Corrected for 1.0.x
Comment 9 Bryan Kearney 2012-07-17 17:03:33 EDT
pulled in the latest.
Comment 10 Bryan Kearney 2012-07-18 11:33:20 EDT
Available in 1.0.10 or later.
Comment 11 Sharath Dwaral 2012-07-24 15:43:02 EDT
Version:
# rpm -qa| egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.10-1.git.25.8954ca8.el5
subscription-manager-1.0.10-1.git.25.8954ca8.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.34.b74ea4f.el5
subscription-manager-firstboot-1.0.10-1.git.25.8954ca8.el5
subscription-manager-gui-1.0.10-1.git.25.8954ca8.el5

Verification:
# msgunfmt --no-wrap /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po
# pofilter --gnome -t options /usr/share/locale/bn_IN/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 13 errata-xmlrpc 2013-01-07 22:53:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.