Bug 828930 - [as] failed pofilter options tests for subscription-manager translations
[as] failed pofilter options tests for subscription-manager translations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
: 828937 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-05 11:12 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:46:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-05 11:12:18 EDT
Description of problem:
The gnome options were not properly translated for 'as' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:


Steps to Reproduce:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/as/LC_MESSAGES/rhsm.mo -o /usr/share/locale/as/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t options /usr/share/locale/as/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-11 12:32-0400\n"
"Last-Translator: ngoswami <ngoswami@fedoraproject.org>\n"
"Language-Team: Assamese <kde-i18n-doc@kde.org>\n"
"Language: as\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) options: Missing or translated option '--username'
msgid "Error: you must register or specify --username and password to list service levels"
msgstr "ত্ৰুটি: আপুনি সেৱা স্তৰসমূহ তালিকাভুক্ত কৰিবলে "

# (pofilter) options: Missing or translated option '--all'
msgid "One of --serial or --all must be provided"
msgstr "হৈতো --serial নহলে -all যোগান ধৰিব লাগিব"


Actual results:
Shown above

Expected results:

>the msgstr should contain the option '--username'. It should not be translated.

msgid "Error: you must register or specify --username and password to list service levels"
msgstr "ত্ৰুটি: আপুনি সেৱা স্তৰসমূহ তালিকাভুক্ত কৰিবলে "

msgid "One of --serial or --all must be provided"
>msgstr "হৈতো --serial নহলে --all যোগান ধৰিব লাগিব"

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#options
Comment 2 Bryan Kearney 2012-06-05 22:31:18 EDT
*** Bug 828937 has been marked as a duplicate of this bug. ***
Comment 4 Nilamdyuti 2012-06-25 12:34:56 EDT
Corrected the above mentioned error in Subscription Manager 0.99.x and 1.0.x as well in https://translate.zanata.org/.
Comment 5 Bryan Kearney 2012-06-25 16:31:26 EDT
Fixed in master via newer transltions or other fixes.

[bkearney@bkearney po]$ pofilter --gnome -t options as.po 
processing 1 files...
[###########################################] 100%
[bkearney@bkearney po]$
Comment 6 Sharath Dwaral 2012-07-16 16:50:25 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.0.9-1.git.22.35b5155.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5

Verification:
# msgunfmt --no-wrap /usr/share/locale/as/LC_MESSAGES/rhsm.mo -o /usr/share/locale/as/LC_MESSAGES/rhsm.po
# pofilter --gnome -t options /usr/share/locale/as/LC_MESSAGES/rhsm.poprocessing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 7 Bryan Kearney 2013-01-09 12:46:00 EST
Batch change of verified bugs which must have missed making the errata.

Note You need to log in before you can comment on or make changes to this bug.