Bug 82894 - lists behave strangely when selecting items
lists behave strangely when selecting items
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
9
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-28 02:14 EST by Thomas M Steenholdt
Modified: 2007-03-27 00:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 01:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2003-01-28 02:14:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a) Gecko/20021212

Description of problem:
GTK2 Lists behave strangely when selecting an item within the list...

To name a few examples of the problem, the Xscreensaver configuration tool,
where you select which screensaver to preview, try using the slider to somewhere
near the middle of the list and select one of the items in the list(I scrolled
to where I can see the "Lament" item in the list, and pressed that one) and
immediately was kicked to "Attraction" via "Anemone"... Trying again
works(Unless you restarted the application).

The same problem is seen in Anaconda(graphical)... An example is where you
select the system locale... Same symptoms - See bug #82380 for more info on this
one!

If this is truely a GTK2 problem, which i very much suspect, since it's the
exact same problem in multiple GTK2 apps, it's rather critical, so i'm setting a
higher priority for this one. If you don't agree with this, please change it to
something more appropriate.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start "Screensaver" from the preferences menu in Gnome
2. Scroll the list of installed screensavers by clicking or dragging the slider,
so that the slider is near the center of the bar.
3. Click on one of the items in the list and watch closely what happens
    

Actual Results:  The item clicked is not the one selected, the list is scrolled
to the top and a different item is selected. Trying again makes it work.
Restarting the application and trying again makes it sick again!

Expected Results:  The clicked item should be selected!!!

Additional info:
Comment 1 Owen Taylor 2003-01-28 11:02:32 EST
What version of gtk2? (rpm -q gtk2)
Comment 2 Thomas M Steenholdt 2003-01-28 12:28:13 EST
rpm -q gtk2 says: gtk2-2.2.0-3
Comment 3 Matthias Clasen 2004-05-13 01:25:16 EDT
This works fine for me with gtk+-2.4.0

Note You need to log in before you can comment on or make changes to this bug.