Bug 82895 - OpenOffice doesn't work with .UTF8 locales and special national chars.
OpenOffice doesn't work with .UTF8 locales and special national chars.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 100544 117428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-28 02:37 EST by Thomas M Steenholdt
Modified: 2013-04-01 14:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 14:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2003-01-28 02:37:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3a) Gecko/20021212

Description of problem:
I actually thought i made a bugreport on this some months back, but i can't seem
to find it and this problem is getting annoying as it effectively keeps me from
using OpenOffice in the default setup!

When using OpenOffice applications in Phoebe(and Psyche as well for that
matter), national special special chars like the danish [$aelign; å
ø] and there uppercase equivs. does not work... I can hit the keys as
hard as i like and still nothing is put onto the screen.

starting from a terminal(ex. oowriter) yields the same result, which is expected
as this is surely the way the application is started normally. 
I18N: X Window System doesn't support locale "en_DK.UTF8"
is displayed in the terminal.
But starting it like this: env LANG="en_DK" oowriter makes the problem go away.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux, selecting English(Denmark) as locale
2. start oowriter
3. hit a couple of keys on the keyboard to make sure input is working, then hit
the danish special keys.
    

Actual Results:  Nothing happens when pressing the danish national char keys.

Expected Results:  The national chars should be output just like any other char!

Additional info:
I'm setting prio high as this problems is most likely affecting a significant
amount of users, given the case that UTF8 locales just doen't work correctly.
Now I just hope that this is actually an openoffice bug. Otherwise please advise
on where to move the record.
Comment 1 Thomas M Steenholdt 2003-02-23 15:28:47 EST
Still a problem with Phoebe-3(8.0.94)...

Is somebody already working on this is it not really an openoffice bug???

This didn't work on 8.0 either!!!

I know more than a few people with this problem! Although it can be worked
around, it's an annoying bug!
Comment 2 Thomas M Steenholdt 2003-06-27 05:43:54 EDT
I found that putting a line 'LC_ALL="C"' in /etc/sysconfig/i18n solved the
problem... I've been working on the system for a few days now and it doesn't
seem to have ruined anything else. I'm not entirely sure how the relation
between LANG and LC_ALL works, so please let me know if there is a reason that
it's not already like that???
Comment 3 Thomas M Steenholdt 2003-09-20 13:55:57 EDT
This is STILL a problem.. It HAS been a problem sine whenever openoffice was
included in the redhat distro. If you need me to provide more/better info, or if
I need to take the problem somewhere else, please let me know!
Comment 4 Dan Williams 2004-02-27 11:08:55 EST
What keyboard layout are you using?  I notice you are using "en_DK",
meaning English but Danish locale, is that correct?  Can you point me
to some details on the keyboard mapping that en_DK uses?

Basically, I need to get that keyboard mapping installed and I need to
know what key combinations to press to get the symbols in question. 
Its not a font issue since I can insert that character manually, but
of course you don't want/shouldn't need to do that :)

Thanks!
Dan
Comment 5 Dan Williams 2004-02-27 11:31:40 EST
*** Bug 100544 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2004-03-17 15:13:30 EST
*** Bug 117428 has been marked as a duplicate of this bug. ***
Comment 7 Dan Williams 2004-03-17 15:15:21 EST

*** This bug has been marked as a duplicate of 75863 ***
Comment 8 Thomas M Steenholdt 2004-04-13 07:04:20 EDT
This is still a problem in FC2-test2... It can be overcome by setting
LANG=C on launch, but this should not be required, right?!?
Comment 9 Thomas M Steenholdt 2004-04-13 07:05:22 EDT
Reopening bug to bypass filters - i'm not owner of the duplicate-of bug!

Comment 10 Dan Williams 2004-09-16 14:56:44 EDT
I'm not able to reproduce with the OOo 1.1.2 packages currently in
rawhide.  Please try those and reopen the bug if necessary.
Comment 11 Thomas M Steenholdt 2004-09-18 16:12:24 EDT
Please make sure that the fix is put in RHEL updates as well???

I'm not able to reproduce on FC3-test1 (rawhide actually) either, so
that's good. However... RHEL3 still have this issue! 

Note You need to log in before you can comment on or make changes to this bug.