Bug 828950 - Backport gnustep make base to el5
Backport gnustep make base to el5
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: gnustep-base (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On: 829041
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 11:31 EDT by David Brown
Modified: 2016-09-08 05:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-08 05:01:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnustep base spec file changes (1.30 KB, application/octet-stream)
2012-06-05 11:31 EDT, David Brown
no flags Details

  None (edit)
Description David Brown 2012-06-05 11:31:28 EDT
Created attachment 589568 [details]
gnustep base spec file changes

Description of problem:
I'd like to have gnustep-base updated in EL5

Version-Release number of selected component (if applicable):
gnustep-base-1.20.1-2.el6


How reproducible:
very

Steps to Reproduce:
1. login to a RHEL5 box with EPEL
2. yum install gnustep-base
3.
  
Actual results:
no package

Expected results:
wanted gnustep-base installed

Additional info:
not a bad port backwards once gnustep-make 2.4.0 gets backported.


$ rpmlint ../RPMS/x86_64/gnustep-base-* ../SRPMS/gnustep-base-1.20.1-2.el5.src.rpm 
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/autogsdoc.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/cvtenc.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/xmlparse.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/defaults.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man8/gdomap.8.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/sfparse.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/gdnc.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/gspath.1.gz
gnustep-base.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man1/pldes.1.gz
gnustep-base.x86_64: W: shared-lib-calls-exit /usr/lib64/libgnustep-base.so.1.20.1 exit@GLIBC_2.2.5
gnustep-base-doc.x86_64: W: infopage-not-compressed bz2 /usr/share/info/coding-standards.info.gz
gnustep-base-doc.x86_64: W: infopage-not-compressed bz2 /usr/share/info/manual.info.gz
5 packages and 0 specfiles checked; 0 errors, 12 warnings.
Comment 1 Jochen Schmitt 2012-06-05 12:32:26 EDT
The most current release of gnustep-make is 2.6.2. So I want to ask, why we should take an older release of gnustep-make?

And please don't tell me anything about the rpmlint output. I know that gnustep is not conform to the usale file standards.
Comment 2 David Brown 2012-06-05 15:21:34 EDT
I just found the version in EPEL 6 and backported them since those are the ones we are used to building against here.
Comment 3 David Brown 2012-06-05 16:12:19 EDT
Also seems like gnustep-base needs a newer version of ffi and rhel5 doesn't have it.


checking FFI library usage... configure: error: The ffi library (libffi) does not appear to be working.  Perhaps it's missing or you need a more recent version.  Version 3.0.9 or later should work, and you can find a link to it n the list of packages for download at http://www.gnustep.org/resources/sources.html
Comment 4 David Brown 2012-06-05 16:17:57 EDT
Hmm seems the newest version of gnustep base needs to have a newer libffi library
Comment 6 David Brown 2012-07-15 00:12:30 EDT
Anyone looked at this lately? I'm now a fedora packager and can do other things if you'd like.

Note You need to log in before you can comment on or make changes to this bug.