Bug 828958 - [pt_BR] failed pofilter options test for subscription-manager translations
[pt_BR] failed pofilter options test for subscription-manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
: 829479 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-05 11:56 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-05 11:56:03 EDT
Description of problem:
The gnome options were not properly translated for 'pt_BR' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t options /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: pt_BR\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 09:51-0400\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) options: Missing or translated option '--available'
msgid "date to search on, defaults to today's date, only used with --available (example: %s)"
msgstr "data a buscar, padrão é o dia de hoje, usad com o --disponível (exemplo: %s)"


Steps to Reproduce:

Actual results:
Shown above

Expected results:

>option --available in msgID should not be translated to native language in msgstr.

msgid "date to search on, defaults to today's date, only used with --available (example: %s)"
>msgstr "data a buscar, padrão é o dia de hoje, usad com o --disponível (exemplo: %s)"

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#options
Comment 3 Alex Wood 2012-06-18 12:53:24 EDT
commit 104859cdd5984926a366418df07fe38ef3741f29
Refs: subscription-manager-1.0.2-1-90-g104859c
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Tue Jun 5 17:03:40 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Wed Jun 6 15:38:39 2012 -0400

    828958: --available should not be translated
Comment 4 RHEL Product and Program Management 2012-06-18 13:08:17 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Glaucia Cintra 2012-06-25 22:42:30 EDT
Bug fixed as requested for pt-BR.
Comment 7 Sharath Dwaral 2012-07-12 15:58:49 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Steps:

# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po

# pofilter --gnome -t options /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.poprocessing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: pt_BR\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2012-07-08 08:45-0400\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) options: Missing or translated option '--password'
msgid "Error: you must register or specify --username and --password to list service levels"
msgstr "Erro: Você deve registrar ou especificar --username e --senha para listar os níveis de serviços"
[###########################################] 100%

Actual Result:
As shown above

Expected Result:
msgid "Error: you must register or specify --username and --password to list service levels"
msgstr "Erro: Você deve registrar ou especificar --username e --senha para listar os níveis de serviços"

--password should not be translated in native language

FailedQA
Comment 8 Bryan Kearney 2012-07-17 18:40:52 EDT
fixed in master and in zanata.
Comment 9 Bryan Kearney 2012-07-17 18:42:47 EDT
*** Bug 829479 has been marked as a duplicate of this bug. ***
Comment 10 Bryan Kearney 2012-07-18 11:33:17 EDT
Available in 1.0.10 or later.
Comment 11 Sharath Dwaral 2012-07-24 15:50:04 EDT
Version:
# rpm -qa| egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.10-1.git.25.8954ca8.el5
subscription-manager-1.0.10-1.git.25.8954ca8.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.34.b74ea4f.el5
subscription-manager-firstboot-1.0.10-1.git.25.8954ca8.el5
subscription-manager-gui-1.0.10-1.git.25.8954ca8.el5

Verification:
# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
# pofilter --gnome -t options /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 12 John Sefler 2012-08-10 15:34:50 EDT
Not sure what happened here, but the fix verified in comment 11 appears to have reverted to the original failure...

[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.13-1.git.14.28f8917.el5

[root@jsefler-rhel59 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo | grep "Error: you must register or specify --username and --password to list service levels" -A1
msgid "Error: you must register or specify --username and --password to list service levels"
msgstr "Erro: Você deve registrar ou especificar --username e --senha para listar os níveis de serviços"
                            EXPECTED --password (NOT --senha) ^^^^^^^


Moving status back to ASSIGNED/FailedQA
Comment 13 Ankit Patel 2012-08-13 01:25:56 EDT
(In reply to comment #12)
> msgid "Error: you must register or specify --username and --password to list
> service levels"
> msgstr "Erro: Você deve registrar ou especificar --username e --senha para
> listar os níveis de serviços"
>                             EXPECTED --password (NOT --senha) ^^^^^^^


Hi Glaucia,

Can you please fix this in 1.0.x? also in other versions (if problem exists) if possible.

Thanks!
Ankit
Comment 14 Bryan Kearney 2012-08-13 10:26:03 EDT
I have fixed the translation in zanata, and in the po file. Sending pull request now.
Comment 15 Bryan Kearney 2012-08-13 10:30:15 EDT
fixed in ceba5986eb764db5f3380373c0737f8f0bdb1d2c
Comment 17 John Sefler 2012-09-07 14:07:20 EDT
Verifying Version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager
subscription-manager-1.0.17-1.el5

[root@rhsm-accept-rhel5 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@rhsm-accept-rhel5 ~]# pofilter --gnome -t options /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%


^^^ VERIFIED: The pofilter options test is now 100% passing for lang=pt_BR
Comment 19 errata-xmlrpc 2013-01-07 22:53:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.