Bug 828964 - amsn fails to start due to package snit is missing
amsn fails to start due to package snit is missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amsn (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sander Hoentjen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 12:05 EDT by Richard Allen
Modified: 2012-08-25 20:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 15:40:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2012-06-05 12:05:56 EDT
Description of problem:
when I start amsn, I get:

[ra@hamburger ~]$ amsn
Error in startup script: can't find package snit
    while executing
"package require snit"
    (file "assistant.tcl" line 11)
    invoked from within
"source assistant.tcl"
    ("uplevel" body line 18)
    invoked from within
"uplevel \#0 {

	# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
	source amsncore.tcl
	source audio.tc..."
    (procedure "reload_files" line 2)
    invoked from within
"reload_files"
    (file "/usr/bin/amsn" line 322)


Version-Release number of selected component (if applicable):
[ra@hamburger ~]$ rpm -q amsn
amsn-0.98.4-10.fc17.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. yum install amsn
2. amsn
3.
  
Actual results:
amsn fails to start.

Expected results:
amsn starts and works

Additional info:
This is a x86_64 Fedora 17, fully up 2 date.
Comment 1 Richard Allen 2012-06-05 12:09:01 EDT
I had a ~/.amsn in my $HOME from f16 and I removed it and tried again:

[ra@hamburger ~]$ rm -fr ~/.amsn
[ra@hamburger ~]$ ll -d ~/.amsn
ls: cannot access /home/ra/.amsn: No such file or directory
[ra@hamburger ~]$ amsn
Error in startup script: can't find package snit
    while executing
"package require snit"
    (file "assistant.tcl" line 11)
    invoked from within
"source assistant.tcl"
    ("uplevel" body line 18)
    invoked from within
"uplevel \#0 {

	# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
	source amsncore.tcl
	source audio.tc..."
    (procedure "reload_files" line 2)
    invoked from within
"reload_files"
    (file "/usr/bin/amsn" line 322)

So it's not some broken configs in my $HOME that are causing this.
Comment 2 adriankx 2012-06-18 18:05:18 EDT
i had the same errors and installed tcllib

yum install tcllib --- solved it and now it works perfectly
Comment 3 Kaur 2012-06-24 00:47:12 EDT
Clean and fresh fedora install and amsn install:

[root@ehitajatetee Pocci]# yum install -y amsn amsn-plugins
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package amsn.i686 0:0.98.4-10.fc17 will be installed
---> Package amsn-plugins.i686 0:0.98.4-10.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================
 Package                             Arch                        Version                               Repository                     Size
===========================================================================================================================================
Installing:
 amsn                                i686                        0.98.4-10.fc17                        fedora                         11 M
 amsn-plugins                        i686                        0.98.4-10.fc17                        fedora                        1.2 M

Transaction Summary
===========================================================================================================================================
Install  2 Packages

Total download size: 12 M
Installed size: 22 M
Downloading Packages:
(1/2): amsn-0.98.4-10.fc17.i686.rpm                                                                                 |  11 MB     00:45     
(2/2): amsn-plugins-0.98.4-10.fc17.i686.rpm                                                                         | 1.2 MB     00:03     
-------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                      246 kB/s |  12 MB     00:49     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : amsn-0.98.4-10.fc17.i686                                                                                                1/2 
  Installing : amsn-plugins-0.98.4-10.fc17.i686                                                                                        2/2 
  Verifying  : amsn-plugins-0.98.4-10.fc17.i686                                                                                        1/2 
  Verifying  : amsn-0.98.4-10.fc17.i686                                                                                                2/2 

Installed:
  amsn.i686 0:0.98.4-10.fc17                                       amsn-plugins.i686 0:0.98.4-10.fc17                                      

Complete!
[root@ehitajatetee Pocci]# amsn
Error in startup script: can't find package snit
    while executing
"package require snit"
    (file "assistant.tcl" line 11)
    invoked from within
"source assistant.tcl"
    ("uplevel" body line 18)
    invoked from within
"uplevel \#0 {

	# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
	source amsncore.tcl
	source audio.tc..."
    (procedure "reload_files" line 2)
    invoked from within
"reload_files"
    (file "/usr/bin/amsn" line 322)
[root@ehitajatetee Pocci]#
Comment 4 Sander Hoentjen 2012-07-16 15:40:30 EDT

*** This bug has been marked as a duplicate of bug 823061 ***
Comment 5 Fedora Update System 2012-07-16 15:47:12 EDT
amsn-0.98.9-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/amsn-0.98.9-3.fc17
Comment 6 Fedora Update System 2012-08-17 03:26:52 EDT
amsn-0.98.9-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/amsn-0.98.9-4.fc17
Comment 7 Fedora Update System 2012-08-25 20:22:10 EDT
amsn-0.98.9-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.