Bug 828978 - RHSM: 'User eec371f2-9415-49c0-b42b-b27c42d776a7 is not allowed to access api/candlepin_proxies/get'
RHSM: 'User eec371f2-9415-49c0-b42b-b27c42d776a7 is not allowed to access api...
Status: CLOSED DUPLICATE of bug 828358
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Katello QA List
:
: 829303 (view as bug list)
Depends On:
Blocks: 828358
  Show dependency treegraph
 
Reported: 2012-06-05 13:09 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 13:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-06-05 13:09:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):
CloudForms System Engine Version: 0.1.313-1.el6_3

How reproducible:


Steps to Reproduce:
1. Register a system to katello
2. subscription-manager list --available
3.
  
Actual results:
User eec371f2-9415-49c0-b42b-b27c42d776a7 is not allowed to access api/candlepin_proxies/get

Expected results:
list of pools 

Additional info:

2012-06-05 13:08:13,567 [DEBUG]  @connection.py:209 - Making request: GET /cfse/api/consumers/eec371f2-9415-49c0-b42b-b27c42d776a7/owner
2012-06-05 13:08:13,641 [DEBUG]  @connection.py:218 - Response status: 403
2012-06-05 13:08:13,641 [ERROR]  @managercli.py:65 - exception caught in subscription-manager
2012-06-05 13:08:13,641 [ERROR]  @managercli.py:66 - User eec371f2-9415-49c0-b42b-b27c42d776a7 is not allowed to access api/candlepin_proxies/get
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager", line 78, in <module>
    sys.exit(abs(main() or 0))
  File "/usr/sbin/subscription-manager", line 69, in main
    return managercli.CLI().main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1382, in main
    cmd.main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 233, in main
    self._do_command()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1247, in _do_command
    self.facts, self.options.all, on_date)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 337, in getAvailableEntitlements
    dlist = list_pools(cpserver, consumer_uuid, facts, get_all, active_on)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 315, in list_pools
    owner = uep.getOwner(consumer_uuid)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 481, in getOwner
    return self.conn.request_get(method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 252, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 219, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 239, in validateResponse
    raise RestlibException(response['status'], error_msg)
RestlibException: User eec371f2-9415-49c0-b42b-b27c42d776a7 is not allowed to access api/candlepin_proxies/get
Comment 1 Jeff Weiss 2012-06-05 13:17:44 EDT
subscription-manager-0.96.17-1.el6.x86_64
Comment 2 Garik Khachikyan 2012-06-07 05:01:23 EDT
seems similar bug: not putting as dupl. as there are already some acking process seems started and so. https://bugzilla.redhat.com/show_bug.cgi?id=829303
Comment 4 Garik Khachikyan 2012-06-07 05:52:18 EDT
doh! neither subscription-manager refresh
User 9d9fb135-240c-4f44-a194-3d83761c25f3 is not allowed to access api/candlepin_proxies/get

hehe...
Comment 6 Mike McCune 2012-06-13 11:21:00 EDT
*** Bug 829303 has been marked as a duplicate of this bug. ***
Comment 8 Mike McCune 2012-06-13 13:52:54 EDT

*** This bug has been marked as a duplicate of bug 828358 ***

Note You need to log in before you can comment on or make changes to this bug.