Bug 829014 - Docbook 1.77.1 contains compilation errors in docbook.xsl
Docbook 1.77.1 contains compilation errors in docbook.xsl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 14:57 EDT by Stephen Gallagher
Modified: 2012-06-05 17:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:05:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2012-06-05 14:57:22 EDT
Description of problem:
'xsltproc --catalogs --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/profile-docbook.xsl' returns a compiltion error.

This is breaking builds of SSSD (and I suspect others) because our configure script checks that appropriate style sheets are available.

Version-Release number of selected component (if applicable):
docbook-style-xsl-1.77.1-1.fc18.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Run the above command
 
Actual results:
See detailed error below.

Expected results:
Successful compilation


Additional info:

[sgallagh@sgallagh520 shm]$ xsltproc --catalogs --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/profile-docbook.xsl
Variable $SGML_CATALOG_FILES not set
warning: failed to load external entity "file:///usr/share/sgml/docbook/xsl-stylesheets-1.77.1/VERSION.xsl"
compilation error: file file:///usr/share/sgml/docbook/xsl-stylesheets-1.77.1/html/docbook.xsl line 26 element include
xsl:include : unable to load file:///usr/share/sgml/docbook/xsl-stylesheets-1.77.1/VERSION.xsl
Comment 1 Ondrej Vasik 2012-06-05 17:05:25 EDT
Thanks for report, AFAIK the 1.77.1-1 build was already untagged by nils. I'm aware of this issue, VERSION.xsl is accidently not shipped by the rpm - as upstream still installs VERSION file in Makefile. New build which should fix this issue is now in koji, closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.