Bug 829041 - Backport libffi to el5
Backport libffi to el5
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: libffi (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 828950
  Show dependency treegraph
 
Reported: 2012-06-05 16:17 EDT by David Brown
Modified: 2014-10-06 20:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-06 20:49:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Brown 2012-06-05 16:17:06 EDT
Description of problem:
would be nice to have libffi <= 3.0.9 for updated gnustep-base to be backported.


Version-Release number of selected component (if applicable):
3.0.10-2.fc17

How reproducible:
very

Steps to Reproduce:
1. login to rhel5 box with epel enabled
2. yum install libffi
3.
  
Actual results:
got older libffi 3.0.5

Expected results:
installed newer package libffi >= 3.0.9

Additional info:

Seems just backporting the fc17 version of the src.rpm works just fine.

here's the rpmlint


$ rpmlint ../RPMS/x86_64/libffi-* ../SRPMS/libffi-3.0.10-2.el5.src.rpm 
libffi-devel.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man3/ffi_call.3.gz
libffi-devel.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man3/ffi.3.gz
libffi-devel.x86_64: W: manpage-not-compressed bz2 /usr/share/man/man3/ffi_prep_cif.3.gz
libffi-devel.x86_64: W: infopage-not-compressed bz2 /usr/share/info/libffi.info.gz
libffi.src:45: W: mixed-use-of-spaces-and-tabs (spaces: line 45, tab: line 1)
libffi.src: W: invalid-url Source0: http://sourceware.org/libffi/libffi-3.0.10.tar.gz HTTP Error 404: Not Found
4 packages and 0 specfiles checked; 0 errors, 6 warnings.

URL:
http://dmlb2000.homelinux.org/packages/libffi-3.0.10-2.el5.src.rpm
Comment 1 David Brown 2012-06-05 16:23:38 EDT
*sigh* and epel 6 should also be updated to this one as well.


$ rpmlint ../SRPMS/libffi-3.0.10-2.el6.src.rpm ../RPMS/x86_64/libffi-*
libffi.src: I: enchant-dictionary-not-found en_US
libffi.src:45: W: mixed-use-of-spaces-and-tabs (spaces: line 45, tab: line 1)
libffi.src: W: invalid-url Source0: http://sourceware.org/libffi/libffi-3.0.10.tar.gz HTTP Error 404: Not Found
4 packages and 0 specfiles checked; 0 errors, 2 warnings.

URL:
http://dmlb2000.homelinux.org/packages/libffi-3.0.10-2.el6.src.rpm
Comment 2 David Brown 2012-07-15 00:15:47 EDT
Ping, anyone look at this?
Comment 3 David Brown 2012-08-17 10:28:53 EDT
I'm going to reference the RHEL 6 bug here since that's a partial of what's mentioned here. (#848950)
Comment 4 David Brown 2014-10-06 20:49:02 EDT
As there hasn't been traction on this one for a long time. I'm going to close this one as a WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.