Bug 829044 - [abrt] gnome-boxes-3.4.2-1.fc17: __GI___libc_malloc: Process /usr/bin/gnome-boxes was killed by signal 11 (SIGSEGV)
[abrt] gnome-boxes-3.4.2-1.fc17: __GI___libc_malloc: Process /usr/bin/gnome-b...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-boxes (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
abrt_hash:b93079a1f64b55fa3f76461a6e5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 16:26 EDT by Carlos Soriano
Modified: 2012-10-01 22:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 16:44:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (108.52 KB, text/plain)
2012-06-05 16:26 EDT, Carlos Soriano
no flags Details
File: maps (79.26 KB, text/plain)
2012-06-05 16:26 EDT, Carlos Soriano
no flags Details
File: dso_list (15.86 KB, text/plain)
2012-06-05 16:26 EDT, Carlos Soriano
no flags Details

  None (edit)
Description Carlos Soriano 2012-06-05 16:26:17 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gnome-boxes
crash_function: __GI___libc_malloc
executable:     /usr/bin/gnome-boxes
kernel:         3.3.7-1.fc17.x86_64
pid:            25054
pwd:            /home/carlos
time:           Tue 05 Jun 2012 10:13:26 PM CEST
uid:            1000
username:       carlos

backtrace:      Text file, 111123 bytes
dso_list:       Text file, 16245 bytes
maps:           Text file, 81162 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/carlos/3

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x7d00d _int_malloc libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x7fcb3 malloc libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x1091e6 __vasprintf_chk libc.so.6 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x69be4 virVasprintf libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x5cb20 virLogMessage libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x127ac4 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x1284f6 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x1090f2 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0xf3451 virStreamRecv libvirt.so.0 -
:0f959ca1e748b410792c45376f924aa3eb9fbeda 0xfb4f gvir_stream_receive libvirt-gobject-1.0.so.0 -
:0f959ca1e748b410792c45376f924aa3eb9fbeda 0x13155 - libvirt-gobject-1.0.so.0 -
:0f959ca1e748b410792c45376f924aa3eb9fbeda 0xf0f0 - libvirt-gobject-1.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47ad4 g_main_context_iteration libglib-2.0.so.0 -
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f 0x97dec g_application_run libgio-2.0.so.0 -
:055e2d2da8c4eb51ffbb11817ba4268da0af14f7 0x397a0 _vala_main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=carlos-laptop-fedora
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/carlos/keyring-nkwFUg
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=carlos
:USERNAME=carlos
:MAIL=/var/spool/mail/carlos
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/carlos/.local/bin:/home/carlos/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/carlos
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1144
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/carlos
:SHLVL=1
:LOGNAME=carlos
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-RN24zQ3cQh,guid=7f849cc4b39f9a615305a30f000000c5
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/carlos
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-carlos-VMNRJp/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1148,unix/unix:/tmp/.ICE-unix/1148
:GPG_AGENT_INFO=/run/user/carlos/keyring-nkwFUg/gpg:0:1
:SSH_AUTH_SOCK=/run/user/carlos/keyring-nkwFUg/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-boxes.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=25054
:DESKTOP_STARTUP_ID=gnome-shell-1370-carlos-laptop-fedora-gnome-boxes-1_TIME17224095

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63326                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63326                63326                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/carlos/.xsession-errors
:pos:	117167
:flags:	0102002
:2:/home/carlos/.xsession-errors
:pos:	117167
:flags:	0102002
:3:socket:[741545]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[741547]
:pos:	0
:flags:	02004002
:6:/dev/dri/card0
:pos:	0
:flags:	0100002
:7:/dev/urandom
:pos:	0
:flags:	02100000
:8:socket:[710308]
:pos:	0
:flags:	02000002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[743592]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:socket:[741557]
:pos:	0
:flags:	02004002
:13:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:14:/home/carlos/.cache/tracker/meta.db
:pos:	55296
:flags:	02100000
:15:/home/carlos/.cache/tracker/meta.db-wal
:pos:	394080
:flags:	02100002
:16:/home/carlos/.cache/tracker/meta.db-shm
:pos:	0
:flags:	0100002
:17:anon_inode:inotify
:pos:	0
:flags:	02004000
:18:/dev/urandom
:pos:	0
:flags:	02100000
:19:socket:[743625]
:pos:	0
:flags:	02004002
:20:socket:[710311]
:pos:	0
:flags:	02004002
:21:socket:[746918]
:pos:	0
:flags:	02004002
:22:pipe:[710312]
:pos:	0
:flags:	02000000
:23:pipe:[710312]
:pos:	0
:flags:	02000001
:24:pipe:[744099]
:pos:	0
:flags:	00
:25:pipe:[744099]
:pos:	0
:flags:	01
:26:anon_inode:[timerfd]
:pos:	0
:flags:	04002
:27:socket:[744100]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: b7d39772-5f74-425f-aa2f-e9696878629a
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5587.18
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2801
:System Memory: 7935
:System Swap: 9983
:Vendor: Dell Inc.
:System: XPS L412Z A03
:Form factor: Portable
:Kernel: 3.3.7-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4172:33345:4136:1314) pci, xhci_hcd, USB, N/A
:(6505:4227:4136:1314) pci, atl1c, ETHERNET, AR8151 v2.0 Gigabit Ethernet
:(4332:21001:4136:1314) pci, None, MISC, N/A
:(32902:294:4136:1314) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4136:1314) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1314) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7243:4136:1314) pci, None, PCI/ISA, HM67 Express Chipset Family LPC Controller
:(4318:4176:4136:1314) pci, nouveau, VIDEO, N/A
:(32902:7200:4136:1314) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7188:4136:1314) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:145:32902:21025) pci, iwlwifi, NETWORK, Centrino Advanced-N 6230 AGN
:(32902:7202:4136:1314) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7171:4136:1314) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7206:4136:1314) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1314) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1314) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:7194:4136:1314) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(32902:257:4136:1314) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_carlos--laptop--fedora-lv_root / ext4 4096 4096 13092026 10034250 9903200 3276800 2942536 2942536
:/dev/sda3 /boot ext4 1024 1024 508745 423918 398318 128016 127660 127660
:/dev/mapper/vg_carlos--laptop--fedora-lv_home /home ext4 4096 4096 163695542 157694220 149500992 40968192 40883476 40883476
:

var_log_messages:
:Jun  4 19:25:58 carlos-laptop-fedora yum[6192]: Updated: gnome-boxes-3.4.2-1.fc17.x86_64
:Jun  5 22:13:26 carlos-laptop-fedora kernel: [17736.900120] gnome-boxes[25054] general protection ip:3dbcc7d00d sp:7fff662052e0 error:0 in libc-2.15.so[3dbcc00000+1ac000]
:Jun  5 22:13:31 carlos-laptop-fedora abrt[25853]: Saved core dump of pid 25054 (/usr/bin/gnome-boxes) to /var/spool/abrt/ccpp-2012-06-05-22:13:26-25054 (442662912 bytes)

xsession_errors:
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:8286): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:25054): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:25054): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:25054): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:25054): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
:(gnome-boxes:25054): Clutter-WARNING **: The actor 'ClutterBox' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
Comment 1 Carlos Soriano 2012-06-05 16:26:27 EDT
Created attachment 589635 [details]
File: backtrace
Comment 2 Carlos Soriano 2012-06-05 16:26:30 EDT
Created attachment 589636 [details]
File: maps
Comment 3 Carlos Soriano 2012-06-05 16:26:33 EDT
Created attachment 589637 [details]
File: dso_list
Comment 4 Christophe Fergeau 2012-06-06 04:40:15 EDT
This looks like some memory corruption :-/ Is this crash reproducible? If so, how ?
Comment 5 Christophe Fergeau 2012-07-02 04:50:19 EDT
This may be fixed by http://libvirt.org/git/?p=libvirt-glib.git;a=commit;h=3e73e0cee977fb20dd29db3ccfe85b00cc386c43
I'm saying this because of virNetClientStreamEventTimerUpdate appearing in the backtrace.
Comment 6 Cole Robinson 2012-10-01 16:44:21 EDT
No response from reporter for awhile, and given comment #5 this might already be fixed. Closing as CURRENT_RELEASE. Carlos, if you can still reproduce the crash with latest packages, please reopen.
Comment 7 Carlos Soriano 2012-10-01 22:33:28 EDT
Sorry for non response, I forgot this bug. I can't reproduce, so close the bug is fine.
Thanks

Note You need to log in before you can comment on or make changes to this bug.