Bug 829166 - The virt-clone progress percentage display incorrect when the source guest was not in the default pool in remote host
The virt-clone progress percentage display incorrect when the source guest wa...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 02:35 EDT by Cui Lei
Modified: 2014-07-06 15:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 10:22:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-clone.log (6.67 KB, text/x-log)
2012-06-06 02:35 EDT, Cui Lei
no flags Details
virsh dumpxml log (2.10 KB, text/xml)
2012-06-06 02:36 EDT, Cui Lei
no flags Details
virt-clone-debug-0725 (6.12 KB, text/x-log)
2012-07-24 23:03 EDT, Cui Lei
no flags Details
newdemo_dumpxml_0725 (1.92 KB, text/x-log)
2012-07-24 23:03 EDT, Cui Lei
no flags Details

  None (edit)
Description Cui Lei 2012-06-06 02:35:11 EDT
Created attachment 589742 [details]
virt-clone.log

Description of problem:
The clone progress percentage display incorrect when the source guest was not in the default pool in remote host. The number of progress percentage was too large.

For example:
[root@localhost ~]# virt-clone --connect=qemu+ssh://10.66.7.186/system -o lcui-iscsi-win2003-i386 -n newdemo --file=/var/lib/libvirt/images/newdemo.img
root@10.66.7.186's password:
Allocating 'newdemo.img'                                                               6788346736% [============================================================================]  19 MB/s | 6.8 GB     --:-- ETA


Version-Release number of selected component (if applicable):
RHEL6.3-20120531.0
python-virtinst-0.600.0-8.el6.noarch
qemu-kvm-0.12.1.2-2.295.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. clone a guest from remote host and which was not exist in the default pool.
2. check the progress percentage number

Actual results:
The number is too large

Expected results:
The number should be normal and correct.

Additional results:
Guest in default pool in remote host do not has this issue.
Comment 1 Cui Lei 2012-06-06 02:36:36 EDT
Created attachment 589743 [details]
virsh dumpxml log
Comment 2 Cole Robinson 2012-07-08 18:33:48 EDT
Hmm, strange. Is this regularly reproducible? Can you show

virsh pool-list --all
virsh vol-dumpxml /home/p2v-lcui/lcui-iscsi-win2003-i386-sdb

on the remote host?
Comment 3 Cui Lei 2012-07-24 22:58:19 EDT
(In reply to comment #2)
> Hmm, strange. Is this regularly reproducible? Can you show
> 
> virsh pool-list --all
> virsh vol-dumpxml /home/p2v-lcui/lcui-iscsi-win2003-i386-sdb
> 
> on the remote host?

Hi Cole,
This issue could be regularly reproduced, also another guy could reproduce this issue either.

There are two key words for reproducing this issue: remote host and non-default pool.
Since last issue ENV have been breaked, I have made another ENV to reproduce this issue. Here is the related info.
#virt-clone --connect=qemu+ssh://10.66.6.214/system -o graphic_rhel -n newdemo --file=/var/lib/libvirt/images/newdemo.img
Allocating 'newdemo.img'                                                              803792149% [===========================================================================]  62 MB/s | 820 MB     --:-- ETA

On the remote host:
# virsh pool-list --all
Name                 State      Autostart
-----------------------------------------
andytest             active     no
default              active     yes
nfs                  active     yes
non-default          active     yes

The original guest was in 'non-default' pool

# virsh vol-dumpxml /var/lib/libvirt/images/non-default/graphic_rhel_new.img 
<volume>
  <name>graphic_rhel_new.img</name>
  <key>/var/lib/libvirt/images/non-default/graphic_rhel_new.img</key>
  <source>
  </source>
  <capacity unit='bytes'>10737418240</capacity>
  <allocation unit='bytes'>2651389952</allocation>
  <target>
    <path>/var/lib/libvirt/images/non-default/graphic_rhel_new.img</path>
    <format type='raw'/>
    <permissions>
      <mode>0600</mode>
      <owner>0</owner>
      <group>0</group>
      <label>system_u:object_r:virt_image_t:s0</label>
    </permissions>
  </target>
</volume>

debug info and dumpxml info I would update soon in this bug
Comment 4 Cui Lei 2012-07-24 23:03:10 EDT
Created attachment 600215 [details]
virt-clone-debug-0725
Comment 5 Cui Lei 2012-07-24 23:03:51 EDT
Created attachment 600216 [details]
newdemo_dumpxml_0725
Comment 6 Cole Robinson 2013-04-21 15:12:21 EDT
virtinst has been merged into virt-manager.git. Moving all virtinst bugs to the virt-manager component.
Comment 7 Cole Robinson 2013-06-10 10:22:15 EDT
I couldn't reproduce this issue now, but I think this upstream commit might fix it:

commit 665375db1bdaa4075f90cfd6e736484798ba306e
Author: Leonardo Garcia <lagarcia@br.ibm.com>
Date:   Sun Jun 9 16:19:35 2013 -0300

    Fix progres bar output bug in virt-clone.

Note You need to log in before you can comment on or make changes to this bug.