Bug 829189 - Post-install addition of language packs impossible
Post-install addition of language packs impossible
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 04:03 EDT by Bert DeKnuydt
Modified: 2014-03-16 23:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 16:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert DeKnuydt 2012-06-06 04:03:21 EDT
Don't know under what to file this bug.  Other option is anaconda.

Description of problem:

It used to be possible to install additional language packs, after
the Fedora install, by a simple:

    yum install @german-support

Now, this does nothing for most languages (but not all, Japanese 
e.g. does work).

Version-Release number of selected component (if applicable):

Fedora 17, 
yum-3.4.3-23.fc17.noarch
anaconda-17.29-1.fc17

How reproducible:

Always

Steps to Reproduce:
1. yum install @german-support @dutch-support ...
2. See that nothing happens, even after adding   
        group_package_types=default,mandatory,optional
   in /etc/yum.conf
3.
  
Actual results:

[Under Fedora 17]
>>> yum groupinfo german-support
Loaded plugins: downloadonly, langpacks, presto

Group: German Support
 Language: de


Expected results:

[Under Fedora 16]
Loaded plugins: downloadonly, langpacks, presto
Available Language Groups:
   German Support [de]
Done
[root@xanadu ~]# yum groupinfo german-support
Loaded plugins: downloadonly, langpacks, presto

Group: German Support
 Language: de
 Conditional Packages:
   LabPlot-doc-de
   aspell-de
   autocorr-de
   childsplay-alphabet_sounds_de
   eclipse-nls-de
   [[and more]]]

Additional info:

This is not really a yum error, but is due to a change in the
'comps-f17.xml' file, which defines the 'groups' in the repo.

If you diff the F16 and F17 version, you see that in most languag
packs all rpms with a name '<package>-<language>', like aspell-de
or kde-i18n-German are removed from the group definition.
Comment 1 Bill Nottingham 2012-06-07 17:25:53 EDT
For installing localized packages, use the yum-langpacks plugins. The @foo-support are only used for fonts and input-methods (and will be removed when that can be made to work with langpacks properly.)
Comment 2 Bert DeKnuydt 2012-06-08 02:57:34 EDT
As far as I can understand, yum-langpacks (which I use) is not able to do that.
(Correct me if I'm wrong)

E.g.: I have a fully installed machine with no language-packs at all.
The normal user of the machine leaves and a German speaking one will take
the machine.  Before, a simple yum install @german-support and all was 
done.  With yum-langpacks, at best, I can have yum install the German 
langpacks _for newly installed packages_, after editing 
/etc/yum/pluginconf.d/langpacks.conf.  

Only a 'yum reinstall <almost-everything>'  will drag in the packs.  Unless
I miss something from the rather scanty documentation...

Sorry, but that is not usable, when you juggle with about 15+ languagepacks
amoungst your users. And it's a very serious step backwards.

Only a kind of 'yum update-language-packs' would bring us back to where
we were...

And then I'm not even talking about removing language packs again ...

B.
Comment 3 Bill Nottingham 2012-06-08 11:28:51 EDT
That could be added to the plugin as an additional option - I'll have to look at that.

But the problems of having to maintain static lists of language packs for all packages in comps became untenable, which is why we went to the plugin method.
Comment 4 Julian Alexander Amani 2012-07-13 12:04:01 EDT
I have the same problem.
I can reproduce it on two different machines with fresh Fedora KDE spin installs.
However, I was initially using the gui tool "system-config-language".
After several unsuccessfull changes of the language, I ran "system-config-language" in a terminal:

# sudo system-config-language
Geladene Plugins: langpacks, presto, refresh-packagekit
Warning: Group german-support does not have any packages.

The manual installation described by Bert DeKnuydt does not work either.
Comment 5 Clemens Eisserer 2012-08-03 04:39:15 EDT
Same here.

Tried to set the language with system-config-language, and it fails to install language packages.
Comment 6 Julian Alexander Amani 2012-08-03 05:55:14 EDT
As suggested by Bill Nottingham I added the languages in langpacks.conf (at least that is what I think Bill ment).
It had no effect!
____________________________________________
> cat /etc/yum/pluginconf.d/langpacks.conf
[main]
enabled=1

# specify locales requiring langpacks
#langpack_locales = ja_JP, zh_CN, mr_IN

langpack_locales = de_DE, en_US
_____________________________________________

Additionally I tried different languages with the same result.
From what I can tell, it is impossible to change to a another language in Fedora 17 besides US-English!

Example - selecting French:
sudo system-config-language
Geladene Plugins: langpacks, presto, refresh-packagekit
Warning: Group french-support does not have any packages.

Example - selecting Polish:
sudo system-config-language
Geladene Plugins: langpacks, presto, refresh-packagekit
Warning: Group polish-support does not have any packages.

I suggest to edit the title of this bug accordingly, since it is neither limited to the german language nor to the yum installation method (Bert DeKnuydt).
Comment 7 Bert DeKnuydt 2012-08-03 06:10:02 EDT
As for the title: agreed.  

Is this better? Feel free to suggest something more expressive.
Comment 8 Julian Alexander Amani 2012-08-03 06:13:45 EDT
Perfect!
Thank you for the fast response.
Comment 9 Bill Nottingham 2013-04-30 16:28:45 EDT
'yum langinstall <lang>' should be working a for a release or two now.

Note You need to log in before you can comment on or make changes to this bug.