Bug 829214 - Drivers should be built for Windows 8
Drivers should be built for Windows 8
Status: CLOSED DUPLICATE of bug 834679
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Windows
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks: 782183
  Show dependency treegraph
 
Reported: 2012-06-06 04:51 EDT by Yan Vugenfirer
Modified: 2012-07-17 10:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 10:27:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Vugenfirer 2012-06-06 04:51:26 EDT
1. As a minimum requirement we should be able to sign binaries for Windows 8. Current signtool in latest Windows 7\Windows200R2 DDK doesn't know how to do it.
In this case Windows 7 drivers will be signed for Windows 8 as well.

2. We should be prepared to build native Windows 8 drivers with Windows 8 DDK.

Problem definition:
Build process changed for Windows 8. "build" utility is deprecated and "old" build used on older DDK will not work. Drivers should be build with Visual studio.

Expected outcome:
1. Developers environment that can build drivers for all platforms.

2. Changes in brew that will enable to build drivers for all platforms and will be able to build previous builds (RHEL6.3 and below) as well with old DDK.
Comment 2 Yan Vugenfirer 2012-06-06 04:55:27 EDT
Current action items:

1. Review what changes should be done for each driver.

2. Discuss in two weeks integration steps (± 20.06).
Comment 3 Mike Cao 2012-06-06 05:49:46 EDT
(In reply to comment #2)
> Current action items:
> 
> 1. Review what changes should be done for each driver.
> 
> 2. Discuss in two weeks integration steps (± 20.06).

Hi, Yan 

Do you plan to support windows server 2012 as well ?

Thanks,
Mike
Comment 4 Yan Vugenfirer 2012-06-06 06:37:09 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Current action items:
> > 
> > 1. Review what changes should be done for each driver.
> > 
> > 2. Discuss in two weeks integration steps (± 20.06).
> 
> Hi, Yan 
> 
> Do you plan to support windows server 2012 as well ?
> 
> Thanks,
> Mike

Sure.
Comment 9 Yan Vugenfirer 2012-07-15 07:55:29 EDT
Script infrastructure for Windows 8 builds is ready for virtio library and netkvm.
Comment 10 Ronen Hod 2012-07-17 10:27:14 EDT

*** This bug has been marked as a duplicate of bug 834679 ***

Note You need to log in before you can comment on or make changes to this bug.