Bug 829248 - the CIM and SNMP Password can be set successfully even passwords does not match
the CIM and SNMP Password can be set successfully even passwords does not match
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: ZStream
Depends On:
Blocks: 837061
  Show dependency treegraph
 
Reported: 2012-06-06 06:12 EDT by haiyang,dong
Modified: 2016-04-26 12:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
Previously, when the password and password confirmation entries did not match, the password was still set. This fix enforces the match requirement to set the password and will produce an "Invalid:Password does not match" error if the passwords do not match.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:36:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-06-06 06:12:47 EDT
Description of problem:
Example:
Password=redhat
Confirm Passwrod =redhat123
although it will prompt that "Passwords Do Not Match" on the cim page, but after press "apply" directly, the CIM Password can be set successfully.

SNMP has the same issue.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120531.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh
2. Enter cim page
3. Enter "Password" label with "redhat" and "Confirm Password" label with "redhat123"
4.press "apply" on the cim page directly
5.send CIM requests to the cim server:
#wbemcli ein -noverify https://cim:redhat@10.66.8.234/root/virt:KVM_VirtualSystemManagementService
6.send CIM requests to the cim server:
#wbemcli ein -noverify https://cim:redhat123@10.66.8.234/root/virt:KVM_VirtualSystemManagementService
Actual results:
1. after press "apply" on the cim page directly, the CIM Password can be set successfully.
2. step 5: send CIM requests success
10.66.8.234:5989/root/virt:KVM_VirtualSystemManagementService.SystemCreationClassName="KVM_HostSystem",SystemName="dhcp-8-234.nay.redhat.com",CreationClassName="KVM_VirtualSystemManagementService",Name="Management Service
3.step 6: send CIM requests fail
*
* wbemcli: Http Exception: Invalid username/password.
*


Expected results:
check password match function can work well in CIM confirmation dialog.

Additional info:
Comment 4 Fabian Deutsch 2012-06-27 09:04:33 EDT
The following patches fix this behavior:

http://gerrit.ovirt.org/5745
http://gerrit.ovirt.org/5746

SNMP
On Apply: If any password is given and both passwords don't match, a message appears and snmp does not get de/activated.

CIM
On Apply: If any password is given and don't match, the rules a message appears and CIM does not get activated.
CIM get's de/actiavated if no password is given at all.
Comment 8 chencong 2012-10-14 03:57:29 EDT
verified with rhevh-6.3-20121005.0.el6_3
1.Enter cim page
2.Enter "Password" label with "redhat" and "Confirm Password" label with "redhat123", then press "apply" on the cim page directly.
3.An error window pops up "CIM Password Is Invalid:Password Do Not Match".
4.send CIM requests to the cim server:
#wbemcli ein -noverify https://cim:redhat@10.66.8.234/root/virt:KVM_VirtualSystemManagementService. Fail.
5.send CIM requests to the cim server:
#wbemcli ein -noverify https://cim:redhat123@10.66.8.234/root/virt:KVM_VirtualSystemManagementService. Fail.
6.Enter "Password" label with "redhat" and "Confirm Password" label with "redhat", then press "apply" on the cim page directly.
7.send CIM requests to the cim server:
#wbemcli ein -noverify https://cim:redhat@10.66.8.234/root/virt:KVM_VirtualSystemManagementService. Success.
Comment 9 haiyang,dong 2012-10-14 21:36:53 EDT
The Flag was marked as rhel‑6.4.0+,so need to verified it on rhev-h version 6.4,
i will verified it on 6.4, right now, change it into "ON_QA"
Comment 13 errata-xmlrpc 2013-02-28 11:36:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.