Bug 829250 - The app status is wrong for new scalable jboss app
The app status is wrong for new scalable jboss app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 06:18 EDT by Rony Gong
Modified: 2015-05-14 18:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-06-06 06:18:41 EDT
Description of problem:

The app status is wrong for new scalable jboss application, only happened for jboss application.


Version-Release number of selected component (if applicable):
devenv_1819
rhc-0.94.1-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
disable auto scaling in server instance
1.create scalable jbossas application
2.use command: rhc-ctl-app -a jboss -c status
3.
  
Actual results:
I could access the url success,but the command result is wrong

[root@localhost ~]# rhc-ctl-app -a q1sjboss -c status
Password: 


RESULT:
Application 'q1sjboss' is either stopped or inaccessible
tailing /var/lib/stickshift/230b8beb55f8486dacb1a95e305efc19/230b8beb55//jbossas-7/standalone/log/server.log
------ Tail of 230b8beb55 application server.log ------
2012/06/06 06:04:53,145 INFO  [org.jboss.as.messaging] (MSC service thread 1-1) JBAS011601: Bound messaging object to jndi name java:/topic/test
2012/06/06 06:04:53,185 INFO  [org.jboss.as.messaging] (MSC service thread 1-1) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/topic/test
2012/06/06 06:04:53,241 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-2) JBAS010406: Registered connection factory java:/JmsXA
2012/06/06 06:04:53,309 INFO  [org.hornetq.ra.HornetQResourceAdapter] (MSC service thread 1-2) HornetQ resource adaptor started
2012/06/06 06:04:53,311 INFO  [org.jboss.as.connector.services.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-2) IJ020002: Deployed: file://RaActivatorhornetq-ra
2012/06/06 06:04:53,316 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-1) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
2012/06/06 06:04:53,411 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.0.Final "Thunder" started in 24708ms - Started 170 of 284 services (111 services are passive or on-demand)
2012/06/06 06:04:53,441 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "ROOT.war"
2012/06/06 06:04:55,816 INFO  [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: 
2012/06/06 06:04:56,086 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "ROOT.war"





Expected results:
the app is started


Additional info:
Comment 1 Paul Morie 2012-09-24 13:40:23 EDT
I cannot reproduce this issue. I created a scalable jboss app as follows:

rhc app create -a jbosseap -t jbosseap-6.0 -s

Both 'rhc app status' and 'rhc-app-ctl -a jbosseap -c status' show the correct status.
Comment 2 Rony Gong 2012-09-25 03:33:24 EDT
verified on devenv_2222
[qgong@localhost dev]$ rhc-ctl-app -a qsjboss -c status
Password: 


RESULT:
tailing /var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss//jbossas-7/standalone/log/server.log
------ Tail of qsjboss application server.log ------
2012/09/25 03:27:44,275 INFO  [org.jboss.as.messaging] (MSC service thread 1-1) JBAS011601: Bound messaging object to jndi name java:/topic/test
2012/09/25 03:27:44,278 INFO  [org.jboss.as.messaging] (MSC service thread 1-1) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/topic/test
2012/09/25 03:27:44,411 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-2) JBAS010406: Registered connection factory java:/JmsXA
2012/09/25 03:27:44,472 INFO  [org.hornetq.ra.HornetQResourceAdapter] (MSC service thread 1-2) HornetQ resource adaptor started
2012/09/25 03:27:44,475 INFO  [org.jboss.as.connector.services.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-2) IJ020002: Deployed: file://RaActivatorhornetq-ra
2012/09/25 03:27:44,481 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-1) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
2012/09/25 03:27:44,680 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.0.Final "Thunder" started in 19591ms - Started 167 of 281 services (111 services are passive or on-demand)
2012/09/25 03:27:44,868 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "ROOT.war"
2012/09/25 03:27:48,341 INFO  [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: 
2012/09/25 03:27:48,621 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "ROOT.war"
Running Processes:
UID        PID  PPID  C    SZ   RSS PSR STIME TTY          TIME CMD
503      21602     1  0  2365  1664   0 03:27 ?        00:00:00 /bin/sh /var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss//jbossas-7/bin/standalone.sh
503      21772 21602  5 281950 180544 0 03:27 ?        00:00:14 /usr/lib/jvm/jre-1.7.0/bin/java -D[Standalone] -client -Xmx256m -XX:MaxPermSize=128m -XX:+AggressiveOpts -Dorg.apache.tomcat.util.LOW_MEMORY=true -Dorg.jboss.resolver.warning=true -Djava.net.preferIPv4Stack=true -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -Djboss.node.name=qsjboss-qgong6.dev.rhcloud.com -Djgroups.bind_addr=127.0.251.129 -Dorg.jboss.boot.log.file=/var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7/standalone/log/boot.log -Dlogging.configuration=file:/var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7/standalone/configuration/logging.properties -jar /var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7/jboss-modules.jar -mp /var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7/standalone/configuration/modules:/var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7/modules -jaxpmodule javax.xml.jaxp-provider org.jboss.as.standalone -Djboss.home.dir=/var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/jbossas-7
503      24377 24348  1  2298  1332   0 03:32 ?        00:00:00 /bin/bash -e /var/lib/stickshift/3669d27b482042b39bd41aad18c46225/qsjboss/qsjboss_ctl.sh status
503      24380 24377  1  2365  1732   0 03:32 ?        00:00:00 /bin/bash -e /usr/libexec/stickshift/cartridges/embedded/haproxy-1.4/info/bin/app_ctl.sh status
503      24475 24380  0  3342  1064   0 03:32 ?        00:00:00 ps -FCvx -U 503
503      27195     1  0  4109  1388   0 03:29 ?        00:00:00 /usr/sbin/haproxy -f /var/lib/stickshift/3669d27b482042b39bd41aad18c46225//haproxy-1.4/conf/haproxy.cfg -sf 26541
503      27685     1  0 17615 20536   0 03:29 ?        00:00:00 haproxy_ctld                                                                                            
tailing /var/lib/stickshift/f36f7725b5b741829fbe1fde87645dc4/f36f7725b5//jbossas-7/standalone/log/server.log
------ Tail of f36f7725b5 application server.log ------
2012/09/25 03:29:17,691 INFO  [org.jboss.as.messaging] (MSC service thread 1-2) JBAS011601: Bound messaging object to jndi name java:/topic/test
2012/09/25 03:29:17,701 INFO  [org.jboss.as.messaging] (MSC service thread 1-2) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/topic/test
2012/09/25 03:29:17,817 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-1) JBAS010406: Registered connection factory java:/JmsXA
2012/09/25 03:29:17,932 INFO  [org.hornetq.ra.HornetQResourceAdapter] (MSC service thread 1-1) HornetQ resource adaptor started
2012/09/25 03:29:17,966 INFO  [org.jboss.as.connector.services.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-1) IJ020002: Deployed: file://RaActivatorhornetq-ra
2012/09/25 03:29:17,975 INFO  [org.jboss.as.deployment.connector] (MSC service thread 1-2) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
2012/09/25 03:29:18,195 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.0.Final "Thunder" started in 40300ms - Started 167 of 281 services (111 services are passive or on-demand)
2012/09/25 03:29:18,317 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "ROOT.war"
2012/09/25 03:29:22,404 INFO  [org.jboss.web] (MSC service thread 1-1) JBAS018210: Registering web context: 
2012/09/25 03:29:22,866 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "ROOT.war"

Note You need to log in before you can comment on or make changes to this bug.