Bug 829414 - REST API: Unable to reach /api/clusters/<id>/networks/<id> . receive ERROR 405
REST API: Unable to reach /api/clusters/<id>/networks/<id> . receive ERROR 405
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Michael Pasternak
Yaniv Kaul
network
: Regression, TestBlocker
Depends On:
Blocks: 815855
  Show dependency treegraph
 
Reported: 2012-06-06 12:19 EDT by Avi Tal
Modified: 2016-04-22 00:59 EDT (History)
12 users (show)

See Also:
Fixed In Version: si7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Tal 2012-06-06 12:19:29 EDT
Description of problem:
Unable to reach /api/clusters/<id>/networks/<id> or any related path's via GET, POST etc
receive ERROR 405

It blocks me from running automation test.

reproduce:
GET http://.../api/clusters/<id>/networks/<id>

ERROR 405
<html><head><title>JBoss Web/7.0.13..Final-redhat-1 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 405 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The specified HTTP method is not allowed for the requested resource ().</u></p><HR size="1" noshade="noshade"><h3>JBoss Web/7.0.13..Final-redhat-1</h3></body></html
Comment 1 Michael Pasternak 2012-06-06 12:24:48 EDT
are you sure you using GET? and this is not some issue in your code?
this is works for me perfectly well.
Comment 3 Avi Tal 2012-06-07 03:38:56 EDT
I am positive. I use only the browser:
http://<my rhevm address>/api/clusters/82c5e06e-aaf8-11e1-9634-001a4a169763/networks/0259c819-8b34-4174-941e-f42777eed4cf

And i get a very clear page with:
HTTP Status 405
Comment 4 Michael Pasternak 2012-06-12 07:54:51 EDT
this is works, try it on next drop.
Comment 6 Avi Tal 2012-06-17 07:15:57 EDT
Checking in SI6 - Failed

Using firefox to browse:
http://<host>/api/clusters/99408929-82cf-4dc7-a532-9d998063fa95/networks/3c51a2f9-9e6d-40a0-bf30-c34796b7f908

HTTP Status 405 - 
description: The specified HTTP method is not allowed for the requested resource ().
Comment 7 Michael Pasternak 2012-06-18 03:03:02 EDT
ok, this is regression indeed, (actually when bug was reported i couldn't reproduce it on my env., this why no work has been done to fix it).
Comment 8 Michael Pasternak 2012-06-18 05:24:24 EDT
Ori, this bug happen cause RestEasy fails locating methods inherited from super class, did you file bug on this as we discussed?
Comment 9 Oded Ramraz 2012-06-21 14:38:45 EDT
http://aqua-rhel.qa.lab.tlv.redhat.com:8080/api/clusters/99408929-82cf-4dc7-a532-9d998063fa95/networks/00000000-0000-0000-0000-000000000009

<network href="/api/clusters/99408929-82cf-4dc7-a532-9d998063fa95/networks/00000000-0000-0000-0000-000000000009" id="00000000-0000-0000-0000-000000000009"><name>rhevm</name><description>Management Network</description><data_center href="/api/datacenters/86c4547c-bbcc-11e1-a64b-97edcd06f040" id="86c4547c-bbcc-11e1-a64b-97edcd06f040"/><cluster href="/api/clusters/99408929-82cf-4dc7-a532-9d998063fa95" id="99408929-82cf-4dc7-a532-9d998063fa95"/><stp>false</stp><status><state>operational</state></status><display>false</display><mtu>0</mtu><usages><usage>VM</usage></usages><required>true</required></network>

Verified si7

Note You need to log in before you can comment on or make changes to this bug.