Bug 829454 - NoSuchGroup: core
NoSuchGroup: core
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:94b6055dd85c18fab55ac459ada...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 15:34 EDT by A.J. Werkman
Modified: 2012-06-22 11:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 11:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-c5DdS0 (589.86 KB, text/plain)
2012-06-06 15:34 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2012-06-06 15:34:47 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-c5DdS0
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.i686
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Wed 06 Jun 2012 11:34:13 PM CEST
version:        17

anaconda-tb-c5DdS0: Text file, 604012 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/yuminstall.py", line 1718, in selectGroup
:    raise NoSuchGroup, group
:  File "/usr/lib/python2.7/site-packages/pyanaconda/installclasses/fedora.py", line 84, in <lambda>
:    map(lambda x: anaconda.backend.selectGroup(x), ["core"])
:  File "/usr/lib/python2.7/site-packages/pyanaconda/installclasses/fedora.py", line 84, in setGroupSelection
:    map(lambda x: anaconda.backend.selectGroup(x), ["core"])
:  File "/usr/lib/python2.7/site-packages/pyanaconda/backend.py", line 215, in doBasePackageSelect
:    anaconda.instClass.setGroupSelection(anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:NoSuchGroup: core

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=/images/pxeboot/vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.M7Rdbg
:LVM_SUPPRESS_FD_WARNINGS=1
:PWD=/
:MALLOC_PERTURB_=204
:TZ=Europe/Amsterdam
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 A.J. Werkman 2012-06-06 15:34:53 EDT
Created attachment 589992 [details]
File: anaconda-tb-c5DdS0
Comment 2 Chris Lumens 2012-06-08 10:06:39 EDT
Are you doing a live install?  Is this at all reproducible?
Comment 3 A.J. Werkman 2012-06-10 05:54:39 EDT
Yes this is reproducible.

Steps to reproduce:

- Make a USB-drive bootable (I used grub2).
- Put vmlinuz, initrd.img and squashfs.img on the drive
- Place the (empty) directories 'Packages' and 'repodata' on the root of the drive
- Boot using the following grub.cfg:
=======================================================
set default=0
set timeout=20

menuentry 'Test Fedora 17' {
	set gfxpayload=text
	set root=(hd0,1)
	echo 'Start Fedora installation ...'
	linux /boot/vmlinuz.f17 nomodeset noipv4 ip=[2001:xxx:xxx:1::70]::[2001:xxx:xxx:1::1]:64:cfl.digifarma.nl::none nameserver=2001:xxx:xxx:1::1 root=live:LABEL=FEDORA_17
	echo 'Initrd laden ...'
	initrd /boot/initrd.f17
}
=======================================================

If you populate Packages and repodata properly with one or two rpm's it looks like anaconda advances a step further but eventually also crashes.
Comment 4 Chris Lumens 2012-06-22 10:57:44 EDT
Why are you trying to install from media with empty Packages and repodata directories?
Comment 5 Brian Lane 2012-06-22 11:10:57 EDT
There is no way that this will work. Anaconda looks for the Packages/repodata directory on the install media in order to install from DVD. If you want to add your own rpms to the install you can add your own side repo with the UI or kickstart's repo command.

Note You need to log in before you can comment on or make changes to this bug.