Bug 829466 - Cannot register in subscription-manager-gui using on-site Subscription Service
Cannot register in subscription-manager-gui using on-site Subscription Service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: William Poteat
J.C. Molet
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-06 16:46 EDT by J.C. Molet
Modified: 2013-01-07 22:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2012-06-06 16:46:02 EDT
Description of problem:
When using subscription-manager-gui, you cannot register to an on-site Subscription Service.  This blocks all gui testing.

Version-Release number of selected component (if applicable):
subscription-manager-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-firstboot-1.0.2-1.git.2.2b23e6e.el5
python-rhsm-1.0.1-1.git.1.e4fc11c.el5
subscription-manager-migration-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gnome-1.0.2-1.git.2.2b23e6e.el5

How reproducible:
always

Steps to Reproduce:
1. Install a rhel 5.9 system with the above sub-man-gui
2. Fire up the gui
3. Go to System > Register
4. Select "I have access to an on-site Subscription Service..."
5. In the subscription service box, enter in your standalone candlepin
   5a.  I entered in "mgmt5.rhq.lab.eng.bos.redhat.com:8443/candlepin" 
6. Click Next
  
Actual results:
Terminal Log:

Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 191, in on_register_button_clicked
    self.register()
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 203, in register
    self._server_selected()
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 334, in _server_selected
    (hostname, port, prefix) = parse_server_info(local_server)
  File "/usr/share/rhsm/subscription_manager/utils.py", line 74, in parse_server_info
    DEFAULT_PREFIX)
  File "/usr/share/rhsm/subscription_manager/utils.py", line 180, in parse_url
    if result.port is not None:
AttributeError: 'tuple' object has no attribute 'port'


Expected results:
It allows me to to to the next screen so I can enter in my username and password

Additional info:
This makes automation sad :(
Comment 1 RHEL Product and Program Management 2012-06-06 16:57:33 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 William Poteat 2012-07-27 15:19:58 EDT
UI redesign seems to have cleared up the problem.
Comment 4 J.C. Molet 2012-08-13 14:25:00 EDT
New stuff works, tested as of: subscription-manager-gui-1.0.13-1.git.14.28f8917.el5

New positive and negative tests have been incorporated into the automation for this.
Comment 6 errata-xmlrpc 2013-01-07 22:54:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.