Bug 829471 - [ta_IN] failed pofilter unchanged optioon test for subscription-manager translations
[ta_IN] failed pofilter unchanged optioon test for subscription-manager trans...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-06 16:54 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-06 16:54:12 EDT
Description of problem:
Some of gnome English words remanin ubtranslated for 'ta_IN' language.  Sample output is shown below, 

Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t unchanged /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-03-20 02:59-0400\n"
"Last-Translator: ifelix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) unchanged: Consider translating
msgid "%prog [options]"
msgstr "%prog [options]"

# (pofilter) unchanged: Consider translating
msgid "Expires:              \t%-25s"
msgstr "Expires:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Repo Id:              \t%-25s"
msgstr "Repo Id:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Repo Url:             \t%-25s"
msgstr "Repo Url:             \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
msgstr "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"

# (pofilter) unchanged: Consider translating
msgid "org id: %s"
msgstr "org id: %s"


Actual results:
Shown above

Expected results:

> english words not translated to it's respective native language.

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#unchanged
Comment 2 Bryan Kearney 2012-06-22 08:44:07 EDT
Fixed in master at 71ef52f69043d8f05aae23d828c822a536b64a73
Comment 3 RHEL Product and Program Management 2012-06-26 14:09:03 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 Sharath Dwaral 2012-07-12 17:26:28 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5


Verification: 

# msgunfmt --no-wrap /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo -o /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.po

# pofilter --gnome -t unchanged /usr/share/locale/ta_IN/LC_MESSAGES/rhsm.poprocessing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2011-04-01 03:35-0400\n"
"Last-Translator: I Felix <ifelix@redhat.com>\n"
"Language-Team: Tamil <kde-i18n-doc@kde.org>\n"
"Language: ta-IN\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) unchanged: Consider translating
msgid "%prog [options]"
msgstr "%prog [options]"

# (pofilter) unchanged: Consider translating
msgid "org id: %s"
msgstr "org id: %s"

# (pofilter) unchanged: Consider translating
msgid "prod 1, prod2, prod 3, prod 4, prod 5, prod 6, prod 7, prod 8"
msgstr "prod 1, prod2, prod 3, prod 4, prod 5, prod 6, prod 7, prod 8"

# (pofilter) unchanged: Consider translating
msgid "register_dialog_main_vbox"
msgstr "register_dialog_main_vbox"

# (pofilter) unchanged: Consider translating
msgid "registration_dialog_action_area\n"
msgstr "registration_dialog_action_area\n"
[###########################################] 100%


Additional Info:
The above unchanged ids are ignorable cases.

Moving bug to VERIFIED
Comment 8 errata-xmlrpc 2013-01-07 22:54:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.