Bug 829479 - [pt_BR] failed pofilter unchanged option test for subscription manager translations
[pt_BR] failed pofilter unchanged option test for subscription manager transl...
Status: CLOSED DUPLICATE of bug 828958
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-06 17:04 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 18:42:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-06 17:04:29 EDT
Description of problem:
Some of gnome English words remanin ubtranslated for 'ml' language.  Sample output is shown below, 

Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t unchanged /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: pt_BR\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 09:51-0400\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) unchanged: Consider translating
msgid "%prog [options]"
msgstr "%prog [options]"

# (pofilter) unchanged: Consider translating
msgid "%s: error: %s"
msgstr "%s: error: %s"

# (pofilter) unchanged: Consider translating
msgid "<b>HTTP Proxy</b>"
msgstr "<b>HTTP Proxy</b>"

# (pofilter) unchanged: Consider translating
msgid "<b>Product ID:</b>"
msgstr "<b>Product ID:</b>"

# (pofilter) unchanged: Consider translating
msgid "<small><b>Example:</b> proxy.example.com:3128</small>"
msgstr "<small><b>Example:</b> proxy.example.com:3128</small>"

# (pofilter) unchanged: Consider translating
msgid "Arch"
msgstr "Arch"

# (pofilter) unchanged: Consider translating
msgid "Arch:                 \t%-25s"
msgstr "Arch:                 \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Description:          \t%-25s"
msgstr "Description:          \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Enabled:              \t%-25s"
msgstr "Enabled:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Login:"
msgstr "Login:"

# (pofilter) unchanged: Consider translating
msgid "Machine Type:         \t%-25s"
msgstr "Machine Type:         \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Multi-Entitlement:    \t%-25s"
msgstr "Multi-Entitlement:    \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Name:                 \t%-25s"
msgstr "Name:                 \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Pool Id:              \t%-25s"
msgstr "Pool Id:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Product ID:           \t%-25s"
msgstr "Product ID:           \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Quantity:             \t%-25s"
msgstr "Quantity:             \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Repo Id:              \t%-25s"
msgstr "Repo Id:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Repo Name:            \t%-25s"
msgstr "Repo Name:            \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Repo Url:             \t%-25s"
msgstr "Repo Url:             \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Starts:               \t%-25s"
msgstr "Starts:               \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Status"
msgstr "Status"

# (pofilter) unchanged: Consider translating
msgid "Status:               \t%-25s"
msgstr "Status:               \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Version:              \t%-25s"
msgstr "Version:              \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Virtual"
msgstr "Virtual"

# (pofilter) unchanged: Consider translating
msgid "_Help"
msgstr "_Help"

# (pofilter) unchanged: Consider translating
msgid "_Proxy Configuration"
msgstr "_Proxy Configuration"

# (pofilter) unchanged: Consider translating
msgid "org id: %s"
msgstr "org id: %s"

# (pofilter) unchanged: Consider translating
msgid "virtual"
msgstr "virtual"


Actual results:
Shown above

Expected results:

> english words not translated to it's respective native language.

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#unchanged
Comment 1 Sharath Dwaral 2012-06-06 17:15:36 EDT
Description of problem:
>Some of gnome English words remanin ubtranslated for 'pt_BR' language.  Sample output is shown below,
Comment 3 Bryan Kearney 2012-06-25 15:25:33 EDT
fixed in master at a518b3c6fedcb0cb15464fce6d09600f5c721aa9
Comment 4 Glaucia Cintra 2012-06-25 22:51:26 EDT
Translations fixed on Subscription Manager pt-BR as per requested and when applicable. Bug fixed.
Comment 5 RHEL Product and Program Management 2012-06-26 14:08:55 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 Sharath Dwaral 2012-07-16 15:09:13 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.9-1.el5
python-rhsm-1.0.3-1.el5
subscription-manager-debuginfo-1.0.9-1.el5
subscription-manager-gui-1.0.9-1.el5
subscription-manager-migration-data-1.11-1.el5
subscription-manager-1.0.9-1.el5
subscription-manager-firstboot-1.0.9-1.el5

Steps:
# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
# pofilter --gnome -t unchanged /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po

processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: pt_BR\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2012-07-08 08:45-0400\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) unchanged: Consider translating
msgid "%prog [options]"
msgstr "%prog [options]"

....... Ignoring other results.........
 
Actual Results:
As shown above

Expected Results:
msgid "%prog [options]"
msgstr "%prog [options]"

"options" to be transslated

Additioonal Information:

# LANG=pt_BR.UTF8 subscription-manager clean --help
uso: subscription-manager clean [OPÇÕES]

Remova todos os clientes e dados de subscrições locais sem afetar o servidor

options:
  -h, --help  apresenta esta mensagem de ajuda e encerra

[options] -> translated here
Comment 8 Sharath Dwaral 2012-07-16 15:36:10 EDT
FailedQA moving back to NEW
Comment 9 Bryan Kearney 2012-07-17 18:42:47 EDT

*** This bug has been marked as a duplicate of bug 828958 ***

Note You need to log in before you can comment on or make changes to this bug.