Bug 829491 - [it] failed pofilter unchanged option test for subscription manager translations
[it] failed pofilter unchanged option test for subscription manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-06 17:28 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-06 17:28:01 EDT
Description of problem:
Some of gnome English words remanin ubtranslated for 'it' language.  Sample output is shown below, 

Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo -o /usr/share/locale/it/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t unchanged /usr/share/locale/it/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: it\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-10 08:24-0400\n"
"Last-Translator: fvalen <fvalen@fedoraproject.org>\n"
"Language-Team: <it@li.org>\n"
"Language: it\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) unchanged: Consider translating
msgid "Arch"
msgstr "Arch"

# (pofilter) unchanged: Consider translating
msgid "Arch:                 \t%-25s"
msgstr "Arch:                 \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "Auto-subscribe"
msgstr "Auto-subscribe"

# (pofilter) unchanged: Consider translating
msgid "Login:"
msgstr "Login:"

# (pofilter) unchanged: Consider translating
msgid "Multi-Entitlement:    \t%-25s"
msgstr "Multi-Entitlement:    \t%-25s"

# (pofilter) unchanged: Consider translating
msgid "No"
msgstr "No"

# (pofilter) unchanged: Consider translating
msgid "Password:"
msgstr "Password:"

# (pofilter) unchanged: Consider translating
msgid "Password: "
msgstr "Password:"

# (pofilter) unchanged: Consider translating
msgid "Red Hat Subscription Manager"
msgstr "Red Hat Subscription Manager"

# (pofilter) unchanged: Consider translating
msgid "Red Hat Subscription Validity Applet"
msgstr "Red Hat Subscription Validity Applet"

# (pofilter) unchanged: Consider translating
msgid "Release: %s"
msgstr "Release: %s"

# (pofilter) unchanged: Consider translating
msgid "org id: %s"
msgstr "org id: %s"

Actual results:
Shown above

Expected results:

> english words not translated to it's respective native language.

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#unchanged
Comment 2 Francesco Valente 2012-06-26 01:02:49 EDT
Entries checked and the following have been changed:

msgid "org id: %s"
msgstr "id organizzazione: %s"


msgid "Multi-Entitlement:    \t%-25s"
msgstr "Entitlement multipli:    \t%-25s"


msgid "Auto-subscribe"
msgstr "Sottoscrizione automatica"

That is all.

Francesco
Comment 3 Bryan Kearney 2012-07-03 08:56:00 EDT
Deleted a few other translations to force translation.
Comment 4 RHEL Product and Program Management 2012-07-10 13:37:18 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Bryan Kearney 2012-07-17 09:15:49 EDT
New translations are in, moving to ON_QA.
Comment 6 Sharath Dwaral 2012-07-24 17:07:18 EDT
Version:

# rpm -qa| egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.10-1.git.25.8954ca8.el5
subscription-manager-1.0.10-1.git.25.8954ca8.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.34.b74ea4f.el5
subscription-manager-firstboot-1.0.10-1.git.25.8954ca8.el5
subscription-manager-gui-1.0.10-1.git.25.8954ca8.el5



Verification:

# grep -A 1 options /usr/share/locale/it/LC_MESSAGES/rhsm.po
msgid "%prog [options]"
msgstr "%prog [opzioni]"


Moving bug to VERIFIED
Comment 8 errata-xmlrpc 2013-01-07 22:54:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.