Bug 829495 - [pa] failed pofilter unchanged option test for subscription manager translations
[pa] failed pofilter unchanged option test for subscription manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: Adrian Likins
Entitlement Bugs
: i18n, Translation
: 840900 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-06 17:39 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-06 17:39:42 EDT
Description of problem:
Some of gnome English words remanin ubtranslated for 'pa' language.  Sample output is shown below, 

Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/pa/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pa/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t unchanged /usr/share/locale/pa/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 12:48-0400\n"
"Last-Translator: jassy <jassy@fedoraproject.org>\n"
"Language-Team: Punjabi/Panjabi <kde-i18n-doc@kde.org>\n"
"Language: pa\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) unchanged: Consider translating
msgid "%s of %s"
msgstr "%s of %s"

# (pofilter) unchanged: Consider translating
msgid "<b>System Facts:</b>"
msgstr "<b>System Facts:</b>"

Actual results:
Shown above

Expected results:

> english words not translated to it's respective native language.

Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#unchanged
Comment 2 Jaswinder Singh 2012-06-29 05:36:17 EDT
msgid "%s of %s" 

was not found in Subscription Manager (1.0.X), It was present in version 0.99.X.

msgid "<b>System Facts:</b>" is fixed in Subscription Manager (1.0.X) and committed at:

https://translate.zanata.org/zanata/project/view/subscription-manager
Comment 3 Bryan Kearney 2012-07-03 14:17:21 EDT
Deleted a mis-translation to force a new translation.
Comment 4 RHEL Product and Program Management 2012-07-10 13:37:12 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Bryan Kearney 2012-07-17 09:16:12 EDT
New translations are in, moving to on_QA.
Comment 6 Sharath Dwaral 2012-07-17 10:43:53 EDT
Description of problem:
The version is not translated.

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5


How reproducible:
Always

Steps to Reproduce:
1. # msgunfmt --no-wrap /usr/share/locale/pa/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pa/LC_MESSAGES/rhsm.po
2.# pofilter --gnome -t unchanged /usr/share/locale/pa/LC_MESSAGES/rhsm.poprocessing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: l 10n\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-07-09 15:06-0400\n"
"PO-Revision-Date: 2012-06-29 05:27-0400\n"
"Last-Translator: jassy <jassy@fedoraproject.org>\n"
"Language-Team: Punjabi/Panjabi <kde-i18n-doc@kde.org>\n"
"Language: pa\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: Zanata 1.6.1\n"

# (pofilter) unchanged: Consider translating
msgid "<b>python-rhsm version:</b> %s"
msgstr "<b>python-rhsm version:</b> %s"

.......... Ignoring other results...............
  
Actual results:
As shown above

Expected results:
msgid "<b>python-rhsm version:</b> %s"
msgstr "<b>python-rhsm version:</b> %s"

the word "version" not translated

Additional info:

The word "version is translated in every other string except this"

# grep -A 1 version /usr/share/locale/pa/LC_MESSAGES/rhsm.po

"This software is licensed to you under the GNU General Public License, version 2 (GPLv2). There is NO WARRANTY for this software, express or implied, including the implied warranties of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. You should have received a copy of GPLv2 along with this software; if not, see:\n"
"\n"
--
msgid "<b>python-rhsm version:</b> %s"
msgstr "<b>python-rhsm version:</b> %s"

msgid "<b>subscription management service version:</b> %s"
msgstr "<b>ਮੈਂਬਰੀ ਮੈਨੇਜਮੈਂਟ ਸਰਵਿਸ ਵਰਜਨ:</b> %s"
--
msgid "No release versions available, please check subscriptions."
msgstr "ਕੋਈ ਰੀਲਜ਼ ਵਰਜਨ ਉਪਲੱਬਧ ਨਹੀਂ ਹੈ, ਮੈਂਬਰੀਆਂ ਜਾਂਚੋ ਜੀ।"
--
msgid "Print version information"
msgstr "ਵਰਜਨ ਜਾਣਕਾਰੀ ਪ੍ਰਿੰਟ ਕਰੋ"
--
msgid "Release version:"
msgstr "ਰੀਲੀਜ਼ ਵਰਜਨ:"
--
msgid "set a release version"
msgstr "ਰੀਲੀਜ਼ ਵਰਜਨ ਸੈੱਟ ਕਰੋ"
--
msgid "show program's version number and exit"
msgstr "ਪਰੋਗਰਾਮ ਦਾ ਵਰਜਨ ਨੰਬਰ ਵੇਖਾਓ ਅਤੇ ਬਾਹਰ ਜਾਓ"


FailedQA moving bug to NEW
Comment 7 Sharath Dwaral 2012-07-17 10:44:51 EDT
*** Bug 840900 has been marked as a duplicate of this bug. ***
Comment 8 Jaswinder Singh 2012-07-18 02:19:48 EDT
Translation is fixed in 1.0.x.

Get it from:
 https://translate.zanata.org/zanata/project/view/subscription-manager
Comment 9 Adrian Likins 2012-08-02 13:07:42 EDT
commit b55f33f5c1ba95129c3938e0ffb0181314fa985f
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Aug 1 16:25:13 2012 -0400

    843113: latest strings from zanata
    
    829495,829494,828954,828576,825393,825367
Comment 10 Sharath Dwaral 2012-08-03 10:22:59 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.12-1.git.6.1cb2247.el5
subscription-manager-1.0.12-1.git.6.1cb2247.el5
subscription-manager-firstboot-1.0.12-1.git.6.1cb2247.el5
python-rhsm-1.0.4-1.git.7.47e5112.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-gui-1.0.12-1.git.6.1cb2247.el5

Verification:

# msgunfmt --no-wrap /usr/share/locale/pa/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pa/LC_MESSAGES/rhsm.po
# pofilter --gnome -t unchanged /usr/share/locale/pa/LC_MESSAGES/rhsm.po | grep "version"
processing 1 files...
[###########################################] 100%

Moving Bug to VERIFIED
Comment 12 errata-xmlrpc 2013-01-07 22:54:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.