Bug 82950 - Cursor artifacts in oowriter (and in other programs too)
Summary: Cursor artifacts in oowriter (and in other programs too)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 21:42 UTC by ingvar
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 03:15:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log file (110.22 KB, text/plain)
2003-02-18 06:44 UTC, ingvar
no flags Details
My XF86Config (XFree86-4.2.0-72) as requested (3.07 KB, text/plain)
2003-02-18 06:47 UTC, ingvar
no flags Details

Description ingvar 2003-01-28 21:42:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
When writing text in oowriter, and then selecting text by dragging the mouse
cursor, and deselect it by clicking anywhere, there are visible misartifacts in
the text. Same thing sometimes happen when moving writing cursor from side to
side using the left and right arrow keys. I believe this has something to do
with a bad combination of blinking cursors and the selection of fonts.

This is also a problem (even more visible) in Evolution and Mozilla, though I'm
not sure it's worth posting a bug if the problem is the same.

Could it be a solution to just switch off cursor blinking in these three
programs? In that case, how?

Ingvar

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
As described above.
1. Enter som text in oowriter
2. Drag to select the text. Deselect it. Repeat a couple of times
   Or just move the text cursor from side to side with left and right 
   arrow keys

Actual Results:  Misartifacts in the text

Expected Results:  No artifacts

Additional info:

The artifacts (of course) goes away if one forces X to redraw, like when
changing display or minimizing the window, and put it back.

Comment 1 Mike A. Harris 2003-02-17 20:00:23 UTC
That would be a video driver bug of some kind.  What video card do you have?

Please attach as text/plain your X server log and config file using the
link below.  Thanks.



Comment 2 ingvar 2003-02-18 06:44:30 UTC
Created attachment 90147 [details]
XFree86 log file

Providing my XFree86.log as requested

Comment 3 ingvar 2003-02-18 06:47:14 UTC
Created attachment 90148 [details]
My XF86Config (XFree86-4.2.0-72) as requested

Comment 4 Mike A. Harris 2003-04-16 03:15:21 UTC
Please try upgrading to Red Hat Linux 9 and see if the new nv driver works
better.  If not and the problem still persists, file a bug report upstream
in XFree86.org's bugzilla at:  http://bugs.xfree86.org


Note You need to log in before you can comment on or make changes to this bug.