Bug 829546 - KID3-2.1 is available
KID3-2.1 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kid3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 22:28 EDT by Gerald Cox
Modified: 2012-06-09 15:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 10:28:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2012-06-06 22:28:03 EDT
Description of problem:

Latest upstream release:  2.1
Current release in F17:  2.0.1-2

According to the Fedora build system, the 2.1 release has been built and put in the F18 repository:  
http://koji.fedoraproject.org/koji/buildinfo?buildID=318666

This 2.1 release contains bug fixes and additional functionality.  Can it be made available in the F17 repository?

Thanks!


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ville Skyttä 2012-06-07 10:28:22 EDT
Most likely not, because in 2.1 musicbrainz support requires ffmpeg which cannot be included in Fedora, and thus upgrading to 2.1 in F-17 would mean loss of functionality which as I interpret it is against the intent of Fedora's stable release updates policy.

At least kid3-qt from Rawhide works on F-17 (yum --enablerepo=rawhide upgrade kid-qt).  Haven't checked the main kid3 package, but if you need the features in 2.1, I suggest trying out the F-18 build.
Comment 2 Gerald Cox 2012-06-09 14:26:15 EDT
Thanks for your response, but I'm confused... if there is a problem with 2.1 regarding ffmpeg why is it in the F-18 repository?  

Would it be better to then move kid3 then to the RPMFUSION repository or are there plans to compartmentalize the musicbrainz functionality as a separate plugin in the same manner that amarok/qmmp etc. handle mp3 support?  In other words, the main program would remain in Fedora, but the musicbrainz part would be in rpmfusion.
Comment 3 Ville Skyttä 2012-06-09 15:06:43 EDT
(In reply to comment #2)
> Thanks for your response, but I'm confused... if there is a problem with 2.1
> regarding ffmpeg why is it in the F-18 repository?

Changing feature sets between releases are a fact of life, and Fedora is a forward moving distribution, and F-18 is the development repo, most bleeding edge of it.  I'm not sure if this is what you asked though - there's no ffmpeg in Fedora so there's no problem with it in kid3 either...

I have no idea about your second question but I will point out to upstream what the ffmpeg dependency means to the kid3 package in Fedora.

Note You need to log in before you can comment on or make changes to this bug.