Bug 829638 - After updating to cups-1.5.3-2.fc17, sometimes my USB printer stops working
After updating to cups-1.5.3-2.fc17, sometimes my USB printer stops working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 03:21 EDT by Joachim Backes
Modified: 2012-08-20 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-11 08:13:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshoot.txt (73.19 KB, text/plain)
2012-06-07 06:00 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2012-06-07 03:21:08 EDT
Description of problem:
I updated cups-1.5.2-12.fc17.x86_64 and cups-libs-1.5.2-12.fc17.x86_64 to cups-
1.5.3-2.fc17 and cups-libs-1.5.3-2.fc17 from updates testing repo. Initially it seems to work. But sometimes the printer stops working, and I see some messages in /var/log/cups/error_log:

W [07/Jun/2012:08:44:24 +0200] failed to find device: cups-ML-1660
W [07/Jun/2012:08:44:24 +0200] failed to find device: cups-PDF
W [07/Jun/2012:08:56:09 +0200] failed to find device: cups-ML-1660
W [07/Jun/2012:08:56:09 +0200] failed to find device: cups-PDF
W [07/Jun/2012:08:56:51 +0200] failed to find device: cups-ML-1660
W [07/Jun/2012:08:56:51 +0200] failed to find device: cups-PDF

Restarting cups does not help - I have to reboot.

Nothing to see in /var/log/messages.

The printer cups-ML-1660 is a Samsung ml-1660 USB printer, and cups-PDF is a PDF-printer installed by cups-pdf-2.6.1-1.fc17.x86_64.

Version-Release number of selected component (if applicable):
cups-1.5.3-2.fc17
cups-libs-1.5.3-2.fc17


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Popelka 2012-06-07 05:38:31 EDT
The "failed to find device" comes from the colord support part of cups and I think it's unrelated to your problem.

You wrote that it's USB printer and cups-1.5.3 has improved USB backend based on libusb-1 so there could be some relation.

When the USB printer stops working are you still able to print to the PDF-printer ?

Once it stops working again please try print something via the printing troubleshooter and attach the output here.
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
Comment 2 Joachim Backes 2012-06-07 06:00:04 EDT
Created attachment 590146 [details]
troubleshoot.txt

(In reply to comment #1)
> The "failed to find device" comes from the colord support part of cups and I
> think it's unrelated to your problem.
> 
> You wrote that it's USB printer and cups-1.5.3 has improved USB backend
> based on libusb-1 so there could be some relation.
> 
> When the USB printer stops working are you still able to print to the
> PDF-printer ?
> 

NO!

> Once it stops working again please try print something via the printing
> troubleshooter and attach the output here.
> https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter

See attachment!
Comment 3 Jiri Popelka 2012-06-07 06:40:24 EDT
(In reply to comment #2)
> See attachment!

It looks good to me.

So there was nothing printed out ?
And it's not printing anymore until you reboot ?
Comment 4 Joachim Backes 2012-06-07 07:15:25 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > See attachment!
> 
> It looks good to me.
> 
> So there was nothing printed out ?
> And it's not printing anymore until you reboot ?

After rebooting, I can print once. But if I try to print for a second time, then 2 standard messages appear at the bottom of the gnome3 desktop:

1. printing on ml-1660 ...
2. printing completed ...

But nothing is printed. If I print again something, then the previously missing printout is printed, but not the actually is printed. And so on: I short words, I have to print each time twice for getting the first output of the 2 print jobs.

No such behaviour with 

 cups              x86_64         1:1.5.2-12.fc17
 cups-libs         x86_64         1:1.5.2-12.fc17
Comment 5 Joachim Backes 2012-08-11 08:13:58 EDT
seems to be solved with

cups-1.5.4-1.fc17.x86_64
cups-libs-1.5.4-1.fc17.x86_64
cups-libs-1.5.4-1.fc17.i686
Comment 6 Jeff lats 2012-08-19 05:09:31 EDT
I have the problem and have following installed

cups-1.5.4-1.fc17.x86_64
cups-libs-1.5.4-1.fc17.x86_64
cups-libs-1.5.4-1.fc17.i686
Comment 7 Jeff lats 2012-08-19 05:14:10 EDT
My problem seems a little different.  My file prints then stops half way and then won't restart printing.
Comment 8 Jiri Popelka 2012-08-20 05:37:22 EDT
Jeff, fill a new bug report and attach an output from printing troubleshooter:
http://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter

Do you see the problem when you downgrade back to 1.4.2 with:
yum downgrade 'cups*'
?
Comment 9 Jeff lats 2012-08-20 09:12:24 EDT
I have changed my printer defintion to be Canon iP3500 which has not been previously available and the printer now works.

Note You need to log in before you can comment on or make changes to this bug.